summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-10-14 10:20:32 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-10-14 10:20:32 +0000
commit591d615232f9d7e82f613bcfbb62e360b893587b (patch)
tree50635ca51ac0709eec303f008cd8a6bacd05e1e6
parentMake output nicer by using %02d for time and date fields. (diff)
WITH_OGG vs. WITH_LIBOGG in some ports
There are so many ports in FreeBSD, that has libogg dependency (transcode, vlc, mplayer, etc). But at least one of them, audio/lopster use an incorrect name - all of them use the WITH(OUT)?_OGG, but lopster uses the (I think) incorrect WITH(OUT)?_LIBOGG make variable. PR: ports/87398 Submitted by: Zahemszky Gabor <gabor@zahemszky.hu>
-rw-r--r--audio/lopster/Makefile8
-rw-r--r--net-p2p/lopster/Makefile8
2 files changed, 8 insertions, 8 deletions
diff --git a/audio/lopster/Makefile b/audio/lopster/Makefile
index dd9cd13884b6..6879fae8c41e 100644
--- a/audio/lopster/Makefile
+++ b/audio/lopster/Makefile
@@ -27,10 +27,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libogg.so.4)
-WITH_LIBOGG= yes
+WITH_OGG= yes
.endif
-.if defined(WITH_LIBOGG)
+.if defined(WITH_OGG)
LIB_DEPENDS+= ogg.5:${PORTSDIR}/audio/libogg
.endif
@@ -41,8 +41,8 @@ CONFIGURE_ARGS+= --with-zlib=no
.endif
pre-everything::
-.ifndef WITH_LIBOGG
- @${ECHO_MSG} "You can specify WITH_LIBOGG to include Ogg support"
+.ifndef WITH_OGG
+ @${ECHO_MSG} "You can specify WITH_OGG to include Ogg support"
.endif
.ifndef WITHOUT_ZLIB
@${ECHO_MSG} "You can specify WITHOUT_ZLIB to disable compression for old servers"
diff --git a/net-p2p/lopster/Makefile b/net-p2p/lopster/Makefile
index dd9cd13884b6..6879fae8c41e 100644
--- a/net-p2p/lopster/Makefile
+++ b/net-p2p/lopster/Makefile
@@ -27,10 +27,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libogg.so.4)
-WITH_LIBOGG= yes
+WITH_OGG= yes
.endif
-.if defined(WITH_LIBOGG)
+.if defined(WITH_OGG)
LIB_DEPENDS+= ogg.5:${PORTSDIR}/audio/libogg
.endif
@@ -41,8 +41,8 @@ CONFIGURE_ARGS+= --with-zlib=no
.endif
pre-everything::
-.ifndef WITH_LIBOGG
- @${ECHO_MSG} "You can specify WITH_LIBOGG to include Ogg support"
+.ifndef WITH_OGG
+ @${ECHO_MSG} "You can specify WITH_OGG to include Ogg support"
.endif
.ifndef WITHOUT_ZLIB
@${ECHO_MSG} "You can specify WITHOUT_ZLIB to disable compression for old servers"