summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-07-23 05:37:49 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-07-23 05:37:49 +0000
commit54c1e4fa8b267d0b98f35c2e4a7f33b0636f44db (patch)
tree925f2ac5e3a0992ceaf8e83d8098839ceea7eebb
parentupdate net/cvsync: 0.24.0 -> 0.24.1 (diff)
fix net/tcpview: Chase AF_{NS/NETBIOS} (bento)
PR: 52124 Submitted by: Volker Stolz <stolz@i2.informatik.rwth-aachen.de>
-rw-r--r--net/tcpview/Makefile4
-rw-r--r--net/tcpview/files/patch-print_null.c20
2 files changed, 20 insertions, 4 deletions
diff --git a/net/tcpview/Makefile b/net/tcpview/Makefile
index 804bb8985872..884349416d16 100644
--- a/net/tcpview/Makefile
+++ b/net/tcpview/Makefile
@@ -22,10 +22,6 @@ MAN1= tcpview.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
post-patch:
.for f in nametoaddr.c addrtoname.c print-nfs.c detail-tcp.c tv_addrtoname.c
@${REINPLACE_CMD} -e 's/NTOHL/ntohl/ ; s/NTOHS/ntohs/' ${WRKSRC}/${f}
diff --git a/net/tcpview/files/patch-print_null.c b/net/tcpview/files/patch-print_null.c
new file mode 100644
index 000000000000..e9d2943a3750
--- /dev/null
+++ b/net/tcpview/files/patch-print_null.c
@@ -0,0 +1,20 @@
+--- print-null.c.orig Mon May 12 17:35:00 2003
++++ print-null.c Mon May 12 17:36:30 2003
+@@ -76,9 +76,17 @@
+ printf("ip: ");
+ break;
+
++#ifdef AF_NS
+ case AF_NS:
+ printf("ns: ");
+ break;
++#endif /* AF_NS */
++#ifdef AF_NETBIOS
++ case AF_NETBIOS:
++ printf("netbios: ");
++ break;
++#endif /* AF_NETBIOS */
++
+
+ default:
+ printf("AF %d: ", family);