summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Vanderhoek <hoek@FreeBSD.org>2004-03-25 04:13:31 +0000
committerTim Vanderhoek <hoek@FreeBSD.org>2004-03-25 04:13:31 +0000
commit44129e386193df4b8d1a96fc61e39de22e25a251 (patch)
treea4f44bb72b496f5eebc7a81d0113a04d450fac54
parentmake it fetchable (diff)
If inews exists in ${PREFIX}/bin/, then use that instead of using
the copy of inews that inn installs in ${PREFIX}/news/lib/inews. The cnews port likes to put inews in ${PREFIX}/bin/. Explanation: The uudeview port generally doesn't use inews, but it has the ability to post items directly to news if the user requests it. The default inews location is hardcoded at compile time. This port does not DEPEND on any particular news software. Requested by: Daeron <daeron -a-t- optushome com au>
-rw-r--r--converters/uudeview/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/converters/uudeview/Makefile b/converters/uudeview/Makefile
index 8e324a406fc6..6862460c02e5 100644
--- a/converters/uudeview/Makefile
+++ b/converters/uudeview/Makefile
@@ -17,8 +17,18 @@ LIB_DEPENDS= uu.3:${PORTSDIR}/converters/uulib
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --enable-inews=${PREFIX}/news/lib/inews \
- --disable-tcl
+CONFIGURE_ARGS= --disable-tcl
+
+.include <bsd.port.pre.mk>
+
+# Try and catch some of the different places that inn and cnews put inews
+.if exists(${PREFIX}/bin/inews)
+# cnews
+CONFIGURE_ARGS+= --enable-inews=${PREFIX}/bin/inews
+.else
+# inn by default
+CONFIGURE_ARGS+= --enable-inews=${PREFIX}/news/lib/inews
+.endif
MAN1= uudeview.1 uuenview.1
@@ -34,4 +44,4 @@ post-install:
@${ECHO_MSG} "===> Not installing available documents"
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>