summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-05-11 12:55:44 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-05-11 12:55:44 +0000
commit3c3f1e3d4134f8dc47a342fe253835806d3a3c37 (patch)
tree1eb2438d51eb2f13d00466aa649cfaa724d62b4c
parentAdd Date::Japanese::Era, that handles conversion between Japanese Era (diff)
Put back gugetopt dependency taken out by marcus. The reason the dependency
is here is to prevent gettext from rolling its own version of getopt_long into the binary, thereby slightly improving code sharing.
-rw-r--r--audio/esound/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/audio/esound/Makefile b/audio/esound/Makefile
index b6f01a744d59..fe6493c6b6d2 100644
--- a/audio/esound/Makefile
+++ b/audio/esound/Makefile
@@ -7,7 +7,7 @@
PORTNAME= esound
PORTVERSION= 0.2.26
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/esound
@@ -15,13 +15,14 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile
+LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
USE_BZIP2= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LIBS="-L${LOCALBASE}/lib -lgnugetopt"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.include <bsd.port.mk>