summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2003-05-07 13:06:05 +0000
committerMichael Landin <mich@FreeBSD.org>2003-05-07 13:06:05 +0000
commit3a9502b54f00afcbb1e6bfce633eb5328271d79b (patch)
tree4dc6c7ee486fa23de03b525cd0b4b654cef8caaa
parentUse libcrypto, not libdes. (diff)
New port.
- p4delta works with a project that is in the Perforce configuration management system. It lists the local files that have been added, changed, or deleted. Content differences are summarized, i.e., the number of lines of code that have been added, changed, and deleted. It can also add, edit, and remove the appropriate files to/from Perforce PR: 51040 Submitted by: me Approved by: roberto (mentor)
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p4delta/Makefile31
-rw-r--r--devel/p4delta/distinfo1
-rw-r--r--devel/p4delta/pkg-descr14
-rw-r--r--devel/p4delta/pkg-plist1
5 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 71d74f878a90..71cfbf0a791c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -427,6 +427,7 @@
SUBDIR += p4.el
SUBDIR += p4api
SUBDIR += p4db
+ SUBDIR += p4delta
SUBDIR += p5-Agent
SUBDIR += p5-Algorithm-Diff
SUBDIR += p5-Algorithm-MDiff
diff --git a/devel/p4delta/Makefile b/devel/p4delta/Makefile
new file mode 100644
index 000000000000..9e96370effc8
--- /dev/null
+++ b/devel/p4delta/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: p4delta
+# Date created: Wed Apr 16, 2003
+# Whom: Michael L. Hostbaek (mich@freebsdcluster.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= p4delta
+PORTVERSION= 1.3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= mich@freebsdcluster.org
+COMMENT= Summarizes and manages differences between local files and Perforce
+
+USE_RUBY= yes
+NO_BUILD= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^#!/usr/bin/ruby|#!${RUBY}|' ${WRKSRC}/p4delta
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/p4delta.1 ${PREFIX}/man/man1/
+
+MAN1= p4delta.1
+
+.include <bsd.port.mk>
diff --git a/devel/p4delta/distinfo b/devel/p4delta/distinfo
new file mode 100644
index 000000000000..f109c4d968d8
--- /dev/null
+++ b/devel/p4delta/distinfo
@@ -0,0 +1 @@
+MD5 (p4delta-1.3.tar.gz) = b93ba5eb211fa3fcd192839bc802bdee
diff --git a/devel/p4delta/pkg-descr b/devel/p4delta/pkg-descr
new file mode 100644
index 000000000000..b8c0dc7e566f
--- /dev/null
+++ b/devel/p4delta/pkg-descr
@@ -0,0 +1,14 @@
+p4delta works with a project that is in the Perforce configuration
+management system. It lists the local files that have been added,
+changed, or deleted. Content differences are summarized, i.e., the
+number of lines of code that have been added, changed, and deleted.
+It can also add, edit, and remove the appropriate files to/from
+Perforce.
+
+Requires ruby.
+
+WWW: http://p4delta.sourceforge.net/
+AUTHOR: Jeff Pace <jpace@incava.org>
+
+ - Michael L. Hostbaek
+ mich@freebsdcluster.org
diff --git a/devel/p4delta/pkg-plist b/devel/p4delta/pkg-plist
new file mode 100644
index 000000000000..7107209425f7
--- /dev/null
+++ b/devel/p4delta/pkg-plist
@@ -0,0 +1 @@
+bin/p4delta