summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2001-02-21 10:23:21 +0000
committerPeter Pentchev <roam@FreeBSD.org>2001-02-21 10:23:21 +0000
commit32be7c61c08a77a056db6aac1ab5698e92d8c227 (patch)
tree855c48e4a2ea79aa2e9f5e675eff3b5c1c02dc79
parentUpdate IPv6 patch to 20010205a. (diff)
Update to look for c-client 4.8 libs.
Disable mcrypt - it seems PHP does not like mcrypt 2.4.x at all :( PR: 25131 Submitted by: Mario Lopez <mario@patas.org> - the c-client alert
-rw-r--r--lang/php/files/patch-configure28
-rw-r--r--lang/php/scripts/configure.php9
2 files changed, 29 insertions, 8 deletions
diff --git a/lang/php/files/patch-configure b/lang/php/files/patch-configure
index dad7927fa15f..84ae84f538a6 100644
--- a/lang/php/files/patch-configure
+++ b/lang/php/files/patch-configure
@@ -1,6 +1,26 @@
---- configure.orig Fri Feb 25 21:49:48 2000
-+++ configure Tue Feb 29 22:29:05 2000
-@@ -8961,7 +8945,7 @@
+--- configure.old Wed Feb 21 11:11:02 2001
++++ configure Wed Feb 21 11:13:29 2001
+@@ -5147,7 +5147,7 @@
+ withval="$with_imap"
+
+ if test "$withval" = "yes"; then
+- if test -f /usr/local/include/mail.h; then
++ if test -f /usr/local/include/c-client/mail.h; then
+ withval=/usr/local
+ elif test -f /usr/include/mail.h; then
+ withval=/usr
+@@ -5157,8 +5157,8 @@
+ fi
+ if test "$withval" != "no" && test "$withval" != "yes"; then
+ IMAP_DIR=$withval
+- if test -f $IMAP_DIR/include/imap/mail.h; then
+- IMAP_INC_DIR=$IMAP_DIR/include/imap
++ if test -f $IMAP_DIR/include/c-client/mail.h; then
++ IMAP_INC_DIR=$IMAP_DIR/include/c-client
+ else
+ IMAP_INC_DIR=$withval/include
+ fi
+@@ -9231,7 +9231,7 @@
fi
SYBASE_CT_INCLUDE=-I$SYBASE_CT_INCDIR
SYBASE_CT_LFLAGS="-L$SYBASE_CT_LIBDIR"
@@ -9,7 +29,7 @@
old_LDFLAGS=$LDFLAGS
LDFLAGS="$LDFLAGS -L$SYBASE_CT_LIBDIR"
echo $ac_n "checking for netg_errstr in -ltcl""... $ac_c" 1>&6
-@@ -9002,7 +8986,6 @@
+@@ -9272,7 +9272,6 @@
SYBASE_CT_LIBS="$SYBASE_CT_LIBS -ltcl"
else
echo "$ac_t""no" 1>&6
diff --git a/lang/php/scripts/configure.php b/lang/php/scripts/configure.php
index ab323d606df4..ae9d95738335 100644
--- a/lang/php/scripts/configure.php
+++ b/lang/php/scripts/configure.php
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/lang/php/scripts/Attic/configure.php,v 1.3 2001-01-21 15:40:39 dirk Exp $
+# $FreeBSD: /tmp/pcvs/ports/lang/php/scripts/Attic/configure.php,v 1.4 2001-02-21 10:23:21 roam Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -76,8 +76,9 @@ while [ "$1" ]; do
ZLIB=1
;;
\"mcrypt\")
- echo "LIB_DEPENDS+= mcrypt.2:\${PORTSDIR}/security/libmcrypt"
- echo "CONFIGURE_ARGS+=--with-mcrypt=\${PREFIX}"
+ #echo "LIB_DEPENDS+= mcrypt.2:\${PORTSDIR}/security/libmcrypt"
+ #echo "CONFIGURE_ARGS+=--with-mcrypt=\${PREFIX}"
+ echo 'mcrypt support does not compile at the moment. Ignoring.' > /dev/stderr
;;
\"mhash\")
echo "mhash is DISABLED for now. Ignoring." > /dev/stderr
@@ -96,7 +97,7 @@ while [ "$1" ]; do
fi
;;
\"IMAP\")
- echo "LIB_DEPENDS+= c-client4.7:\${PORTSDIR}/mail/cclient"
+ echo "LIB_DEPENDS+= c-client4.8:\${PORTSDIR}/mail/cclient"
echo "CONFIGURE_ARGS+=--with-imap=\${PREFIX}"
;;
\"MySQL\")