summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-11-12 10:45:21 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-11-12 10:45:21 +0000
commit3206ad8e7f3a31c1db67cd10bf9578cb806faf38 (patch)
tree3542f9662210d7a77968fea154d1bab2f1745dbe
parentFix a breakage resulted from path to gdk-pixbuf's includes being hardcoded. (diff)
Change permissions of all files in ${PREFIX}/share/gnome/evolution/default_user
to be 644, otherwise after installation the user will be unable to make any changes to his/her mailboxes. See http://bugzilla.ximian.com/show_bug.cgi?id=14961 for details. Submitted by: Christopher Masto <chris@netmonger.net>
-rw-r--r--mail/evolution-devel/Makefile5
-rw-r--r--mail/evolution/Makefile5
2 files changed, 10 insertions, 0 deletions
diff --git a/mail/evolution-devel/Makefile b/mail/evolution-devel/Makefile
index 49d42de01c25..74bc15322350 100644
--- a/mail/evolution-devel/Makefile
+++ b/mail/evolution-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= evolution
PORTVERSION= 0.99.0
+PORTREVISION= 1
CATEGORIES= mail gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/evolution
@@ -45,4 +46,8 @@ pre-patch:
@find ${WRKSRC} -type f -name "*.[ch]" | xargs ${GREP} -l 'wrong DB3' | \
xargs ${PERL} -pi -e 's|.*wrong DB3.*||'
+post-install:
+ @find ${PREFIX}/share/gnome/evolution/default_user -type f | \
+ xargs ${CHMOD} 644
+
.include <bsd.port.mk>
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index 49d42de01c25..74bc15322350 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -7,6 +7,7 @@
PORTNAME= evolution
PORTVERSION= 0.99.0
+PORTREVISION= 1
CATEGORIES= mail gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/evolution
@@ -45,4 +46,8 @@ pre-patch:
@find ${WRKSRC} -type f -name "*.[ch]" | xargs ${GREP} -l 'wrong DB3' | \
xargs ${PERL} -pi -e 's|.*wrong DB3.*||'
+post-install:
+ @find ${PREFIX}/share/gnome/evolution/default_user -type f | \
+ xargs ${CHMOD} 644
+
.include <bsd.port.mk>