summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2003-12-15 06:57:15 +0000
committerMark Linimon <linimon@FreeBSD.org>2003-12-15 06:57:15 +0000
commit2e1ad914a2d0bb88f327ab1c75edc3aec006ab3b (patch)
tree36c33d369665e6bdea4338c613b717c7172486ed
parentUpdate to 0.5.3. (diff)
Mark as only for the various Intel chips. Pet portlint. No objection
from: maintainer. PR: ports/60178 Submitted by: Volker Stolz <stolz@i2.informatik.rwth-aachen.de>
-rw-r--r--lang/gforth/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/lang/gforth/Makefile b/lang/gforth/Makefile
index 00b6ce1c042b..a6124dd63429 100644
--- a/lang/gforth/Makefile
+++ b/lang/gforth/Makefile
@@ -14,6 +14,8 @@ MASTER_SITE_SUBDIR= gforth
MAINTAINER= cyrille.lefevre@laposte.net
COMMENT= Fast and portable Forth system
+ONLY_FOR_ARCHS= i386 amd64 ia64
+
# Global variables
#
@@ -69,19 +71,19 @@ post-install: install-doc install-el remove-empty-files remove-empty-dirs
install-doc:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ${DOC_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.for filename in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${filename} ${DOCSDIR}
.endfor
.endif
install-el:
-.for file in ${EMACS_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${EMACS_DIR}
+.for filename in ${EMACS_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${filename} ${EMACS_DIR}
.endfor
remove-empty-files:
-.for file in ${EMPTY_FILES}
- @${RM} -f ${FORTH_DIR}/${file}
+.for filename in ${EMPTY_FILES}
+ @${RM} -f ${FORTH_DIR}/${filename}
.endfor
remove-empty-dirs: