summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-12 15:02:41 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-12 15:02:41 +0000
commit2e0fa777e6054eff2cfb9b41f54dc90ad332bf35 (patch)
tree89517e21c00c41bfb29e976dbcc51376c65e9555
parentUpdate to 1.4.2 (diff)
This plugin uses "Authen::Htpasswd" to let your application use
".htpasswd" files for it's authentication storage. WWW: http://search.cpan.org/dist/Catalyst-Plugin-Authentication-Store-Htpasswd/ PR: ports/90274 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-Store-Htpasswd/Makefile32
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-Store-Htpasswd/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-Store-Htpasswd/pkg-descr4
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-Store-Htpasswd/pkg-plist8
5 files changed, 48 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 0c83c6d75dc3..96dbabd9ee3e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -497,6 +497,7 @@
SUBDIR += p5-Catalyst-Plugin-Authentication
SUBDIR += p5-Catalyst-Plugin-Authentication-CDBI
SUBDIR += p5-Catalyst-Plugin-Authentication-Store-DBIC
+ SUBDIR += p5-Catalyst-Plugin-Authentication-Store-Htpasswd
SUBDIR += p5-Catalyst-Plugin-Authorization-Roles
SUBDIR += p5-Catalyst-Plugin-DefaultEnd
SUBDIR += p5-Catalyst-Plugin-FillInForm
diff --git a/www/p5-Catalyst-Plugin-Authentication-Store-Htpasswd/Makefile b/www/p5-Catalyst-Plugin-Authentication-Store-Htpasswd/Makefile
new file mode 100644
index 000000000000..2c7d8bc51bc7
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication-Store-Htpasswd/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-Authentication-Store-Htpasswd
+# Date created: Dec 12, 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Authentication-Store-Htpasswd
+PORTVERSION= 0.011
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Use .htpasswd with Catalyst
+
+BUILD_DEPENDS= p5-Catalyst-Plugin-Authentication>=0.01:${PORTSDIR}/www/p5-Catalyst-Plugin-Authentication \
+ p5-Authen-Htpasswd>=0.13:${PORTSDIR}/security/p5-Authen-Htpasswd
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::Authentication::Store::Htpasswd::User.3 \
+ Catalyst::Plugin::Authentication::Store::Htpasswd.3 \
+ Catalyst::Plugin::Authentication::Store::Htpasswd::Backend.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Authentication-Store-Htpasswd/distinfo b/www/p5-Catalyst-Plugin-Authentication-Store-Htpasswd/distinfo
new file mode 100644
index 000000000000..90bb7aaf3c31
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication-Store-Htpasswd/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Authentication-Store-Htpasswd-0.011.tar.gz) = c715b8161a548119f993a6c3e9d2d0c8
+SHA256 (Catalyst-Plugin-Authentication-Store-Htpasswd-0.011.tar.gz) = a066196417a8cd878183b6f65364c703b504d8d80060fc2b881649c452a3696d
+SIZE (Catalyst-Plugin-Authentication-Store-Htpasswd-0.011.tar.gz) = 4003
diff --git a/www/p5-Catalyst-Plugin-Authentication-Store-Htpasswd/pkg-descr b/www/p5-Catalyst-Plugin-Authentication-Store-Htpasswd/pkg-descr
new file mode 100644
index 000000000000..95b13b11712f
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication-Store-Htpasswd/pkg-descr
@@ -0,0 +1,4 @@
+This plugin uses "Authen::Htpasswd" to let your application use
+".htpasswd" files for it's authentication storage.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Authentication-Store-Htpasswd/
diff --git a/www/p5-Catalyst-Plugin-Authentication-Store-Htpasswd/pkg-plist b/www/p5-Catalyst-Plugin-Authentication-Store-Htpasswd/pkg-plist
new file mode 100644
index 000000000000..482f2725a6f5
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication-Store-Htpasswd/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/Htpasswd/User.pm
+%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/Htpasswd/Backend.pm
+%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/Htpasswd.pm
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/Htpasswd 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Authentication 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true