summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-07 18:34:07 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-07 18:34:07 +0000
commit281a55555a7d66ba836bf27f7eb1ad250cadafa4 (patch)
treeaee2285517dec3476da0b7107d9ebce773a63698
parentTie in gnomeuserdocs2. Bump PORTREVISION. (diff)
PERL -> REINPLACE_CMD
PR: 40289 Submitted by: maintainer
-rw-r--r--french/xtel/Makefile6
-rw-r--r--french/xtel/files/patch-Videotex_Videotex.c11
-rw-r--r--lang/njs/Makefile10
-rw-r--r--lang/njs/files/patch-configure11
-rw-r--r--mail/horde-imp/Makefile31
-rw-r--r--mail/horde4-imp/Makefile31
-rw-r--r--mail/imp/Makefile31
-rw-r--r--misc/libmcal/Makefile9
-rw-r--r--www/horde-base/Makefile39
-rw-r--r--www/horde-base/files/patch-secure.sh28
-rw-r--r--www/horde/Makefile39
-rw-r--r--www/horde/files/patch-secure.sh28
-rw-r--r--www/horde4-base/Makefile39
-rw-r--r--www/horde4-base/files/patch-secure.sh28
14 files changed, 240 insertions, 101 deletions
diff --git a/french/xtel/Makefile b/french/xtel/Makefile
index a55da391b536..43c594dd5288 100644
--- a/french/xtel/Makefile
+++ b/french/xtel/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
USE_IMAKE= yes
USE_XPM= yes
+USE_REINPLACE= yes
MAN1= xtel.1 xteld.1
@@ -37,10 +38,9 @@ PATCH_FILES= Imakefile
post-patch:
.for FILE in ${PATCH_FILES}
- @${PERL} -pi -e "s:%%LOCALBASE%%:${LOCALBASE}:g" ${WRKSRC}/${FILE}
+ ${CHMOD} u+w ${WRKSRC}/${FILE}
+ ${REINPLACE_CMD} -e "s:%%LOCALBASE%%:${LOCALBASE}:g" ${WRKSRC}/${FILE}
.endfor
- find ${WRKSRC} -type f | xargs ${PERL} -pi -e \
- "s@#include.*<malloc.h>@#include <stdlib.h>@g"
pre-configure:
.if !exists(${PREFIX}/lib/X11/config/host.def)
diff --git a/french/xtel/files/patch-Videotex_Videotex.c b/french/xtel/files/patch-Videotex_Videotex.c
new file mode 100644
index 000000000000..7b5c4f9bcfd1
--- /dev/null
+++ b/french/xtel/files/patch-Videotex_Videotex.c
@@ -0,0 +1,11 @@
+--- Videotex/Videotex.c.orig Sun Feb 11 01:13:00 2001
++++ Videotex/Videotex.c Sun Jul 7 13:17:57 2002
+@@ -22,7 +22,7 @@
+ /*
+ * Widget Videotex: VideotexWidgetClass
+ */
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <ctype.h>
+ #include <X11/IntrinsicP.h>
+ #include <X11/StringDefs.h>
diff --git a/lang/njs/Makefile b/lang/njs/Makefile
index 24ee902d63c9..e5f5083cc18d 100644
--- a/lang/njs/Makefile
+++ b/lang/njs/Makefile
@@ -18,16 +18,16 @@ MAINTAINER= thierry@pompo.net
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
+.if defined(NOPORTDOCS)
+USE_REINPLACE= yes
+.endif
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-shared
MAN1= js.1 jsdas.1
post-extract:
- ${RM} ${WRKSRC}/docs/js.info*
-
-post-patch:
- ${PERL} -pi -e 's:=makeinfo:="makeinfo --no-split":g' ${WRKSRC}/configure
+ @${RM} ${WRKSRC}/docs/js.info*
pre-configure:
@if [ -f ${LOCALBASE}/include/js.h ]; then \
@@ -39,7 +39,7 @@ pre-configure:
pre-install:
.if defined(NOPORTDOCS)
- ${PERL} -pi -e "s:docs micros examples:micros:g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s:docs micros examples:micros:g" ${WRKSRC}/Makefile
.endif
post-install:
diff --git a/lang/njs/files/patch-configure b/lang/njs/files/patch-configure
new file mode 100644
index 000000000000..26e3d8b7f2df
--- /dev/null
+++ b/lang/njs/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Jan 15 08:39:56 1999
++++ configure Sun Jul 7 14:04:03 2002
+@@ -791,7 +791,7 @@
+ # an executable is not found, even if stderr is redirected.
+ # Redirect stdin to placate older versions of autoconf. Sigh.
+ if (makeinfo --version) < /dev/null > /dev/null 2>&1; then
+- MAKEINFO=makeinfo
++ MAKEINFO="makeinfo --no-split"
+ echo "$ac_t""found" 1>&6
+ else
+ MAKEINFO="$missing_dir/missing makeinfo"
diff --git a/mail/horde-imp/Makefile b/mail/horde-imp/Makefile
index 582d3ae84573..d71c04a3b821 100644
--- a/mail/horde-imp/Makefile
+++ b/mail/horde-imp/Makefile
@@ -93,6 +93,9 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/ispell:${PORTSDIR}/textproc/ispell
.endif
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeImp
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/DATABASE \
docs/HELP docs/INSTALL docs/SECURITY docs/KNOWN_BUGS \
docs/PACKAGES
@@ -173,19 +176,17 @@ do-install:
${CP} -Rp ${WRKSRC}/config ${WRKSRC}/graphics ${WRKSRC}/lib ${IMPDIR}
${CP} -Rp ${WRKSRC}/locale ${WRKSRC}/scripts ${WRKSRC}/templates ${IMPDIR}
${CP} -p ${WRKSRC}/*.php3 ${WRKSRC}/*.css ${IMPDIR}
- ${PERL} -pi -e "s:/usr/bin/ispell:${LOCALBASE}/bin/ispell:g" \
- ${IMPDIR}/config/defaults.php3.dist
- ${PERL} -pi -e "s:/usr/bin/wvHtml:${LOCALBASE}/bin/wvHtml:g" \
- ${IMPDIR}/config/defaults.php3.dist
- ${PERL} -pi -e "s:/usr/bin/xlHtml:${LOCALBASE}/bin/xlhtml:g" \
+ ${REINPLACE_CMD} -e "s:/usr/bin/ispell:${LOCALBASE}/bin/ispell:g ; \
+ s:/usr/bin/wvHtml:${LOCALBASE}/bin/wvHtml:g ; \
+ s:/usr/bin/xlHtml:${LOCALBASE}/bin/xlhtml:g ; \
+ s:/bin/tar:/usr/bin/tar:g ; \
+ s:/usr/bin/zipinfo:${LOCALBASE}/bin/zipinfo:g" \
${IMPDIR}/config/defaults.php3.dist
- ${PERL} -pi -e "s:/bin/tar:/usr/bin/tar:g" ${IMPDIR}/config/defaults.php3.dist
- ${PERL} -pi -e "s:/usr/bin/zipinfo:${LOCALBASE}/bin/zipinfo:g" \
- ${IMPDIR}/config/defaults.php3.dist
- ${PERL} -pi -e "s:sh ./secure.sh:${HORDESBIN}/horde_secure.sh:g" \
- ${IMPDIR}/templates/index/imp_notconfigured.inc
- ${PERL} -pi -e "s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" \
+ @${RM} ${IMPDIR}/config/defaults.php3.dist.beforeImp
+ ${REINPLACE_CMD} -e "s:sh ./secure.sh:${HORDESBIN}/horde_secure.sh:g ; \
+ s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" \
${IMPDIR}/templates/index/imp_notconfigured.inc
+ @${RM} ${IMPDIR}/templates/index/imp_notconfigured.inc.beforeImp
@if [ ! -f ${IMPDIR}/config/defaults.php3 ]; then \
${CP} ${IMPDIR}/config/defaults.php3.dist ${IMPDIR}/config/defaults.php3; \
fi
@@ -205,7 +206,7 @@ do-install:
(if [ ! -f ${APACHE_CONF}.beforeIMP ] ; then \
${ECHO} "===> Updating ${APACHE_CONF}..." ; \
${CP} -p ${.CURDIR}/httpd.conf.imp ${WRKDIR}/httpd.conf.imp ; \
- ${PERL} -pi -e "s:/home/httpd/html/horde/imp:${IMPDIR}:g" \
+ ${REINPLACE_CMD} -e "s:/home/httpd/html/horde/imp:${IMPDIR}:g" \
${WRKDIR}/httpd.conf.imp ; \
${CP} -p ${APACHE_CONF} ${APACHE_CONF}.beforeIMP ; \
${GREP} -qw 'Added for IMP' ${APACHE_CONF} || ${CAT} ${WRKDIR}/httpd.conf.imp \
@@ -213,7 +214,10 @@ do-install:
fi) ; \
fi)
.if !defined(NOPORTDOCS)
- ${PERL} -pi -e "s:/home/httpd/html/horde/imp:${IMPDIR}:g" ${WRKSRC}/docs/SECURITY
+ ${REINPLACE_CMD} -e "s:/home/httpd/html/horde:${HORDEDIR}:g ; \
+ s:/home/httpd/horde-phplib:${HORDEDIR}/phplib:g ; \
+ s:nobody:www:g" \
+ ${WRKSRC}/docs/SECURITY
${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
@@ -248,6 +252,7 @@ post-install:
@${ECHO} "IMAP-UW; you may want to reinstall it with SSL support, or"
@${ECHO} "if you need an SSL connection to your IMAP server, you can"
@${ECHO} "install the port security/stunnel."
+ @${ECHO} "Note: without SSL, you have to choose the IMAP port 143/notls"
@${ECHO} "******************************************************************"
.include <bsd.port.mk>
diff --git a/mail/horde4-imp/Makefile b/mail/horde4-imp/Makefile
index 582d3ae84573..d71c04a3b821 100644
--- a/mail/horde4-imp/Makefile
+++ b/mail/horde4-imp/Makefile
@@ -93,6 +93,9 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/ispell:${PORTSDIR}/textproc/ispell
.endif
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeImp
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/DATABASE \
docs/HELP docs/INSTALL docs/SECURITY docs/KNOWN_BUGS \
docs/PACKAGES
@@ -173,19 +176,17 @@ do-install:
${CP} -Rp ${WRKSRC}/config ${WRKSRC}/graphics ${WRKSRC}/lib ${IMPDIR}
${CP} -Rp ${WRKSRC}/locale ${WRKSRC}/scripts ${WRKSRC}/templates ${IMPDIR}
${CP} -p ${WRKSRC}/*.php3 ${WRKSRC}/*.css ${IMPDIR}
- ${PERL} -pi -e "s:/usr/bin/ispell:${LOCALBASE}/bin/ispell:g" \
- ${IMPDIR}/config/defaults.php3.dist
- ${PERL} -pi -e "s:/usr/bin/wvHtml:${LOCALBASE}/bin/wvHtml:g" \
- ${IMPDIR}/config/defaults.php3.dist
- ${PERL} -pi -e "s:/usr/bin/xlHtml:${LOCALBASE}/bin/xlhtml:g" \
+ ${REINPLACE_CMD} -e "s:/usr/bin/ispell:${LOCALBASE}/bin/ispell:g ; \
+ s:/usr/bin/wvHtml:${LOCALBASE}/bin/wvHtml:g ; \
+ s:/usr/bin/xlHtml:${LOCALBASE}/bin/xlhtml:g ; \
+ s:/bin/tar:/usr/bin/tar:g ; \
+ s:/usr/bin/zipinfo:${LOCALBASE}/bin/zipinfo:g" \
${IMPDIR}/config/defaults.php3.dist
- ${PERL} -pi -e "s:/bin/tar:/usr/bin/tar:g" ${IMPDIR}/config/defaults.php3.dist
- ${PERL} -pi -e "s:/usr/bin/zipinfo:${LOCALBASE}/bin/zipinfo:g" \
- ${IMPDIR}/config/defaults.php3.dist
- ${PERL} -pi -e "s:sh ./secure.sh:${HORDESBIN}/horde_secure.sh:g" \
- ${IMPDIR}/templates/index/imp_notconfigured.inc
- ${PERL} -pi -e "s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" \
+ @${RM} ${IMPDIR}/config/defaults.php3.dist.beforeImp
+ ${REINPLACE_CMD} -e "s:sh ./secure.sh:${HORDESBIN}/horde_secure.sh:g ; \
+ s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" \
${IMPDIR}/templates/index/imp_notconfigured.inc
+ @${RM} ${IMPDIR}/templates/index/imp_notconfigured.inc.beforeImp
@if [ ! -f ${IMPDIR}/config/defaults.php3 ]; then \
${CP} ${IMPDIR}/config/defaults.php3.dist ${IMPDIR}/config/defaults.php3; \
fi
@@ -205,7 +206,7 @@ do-install:
(if [ ! -f ${APACHE_CONF}.beforeIMP ] ; then \
${ECHO} "===> Updating ${APACHE_CONF}..." ; \
${CP} -p ${.CURDIR}/httpd.conf.imp ${WRKDIR}/httpd.conf.imp ; \
- ${PERL} -pi -e "s:/home/httpd/html/horde/imp:${IMPDIR}:g" \
+ ${REINPLACE_CMD} -e "s:/home/httpd/html/horde/imp:${IMPDIR}:g" \
${WRKDIR}/httpd.conf.imp ; \
${CP} -p ${APACHE_CONF} ${APACHE_CONF}.beforeIMP ; \
${GREP} -qw 'Added for IMP' ${APACHE_CONF} || ${CAT} ${WRKDIR}/httpd.conf.imp \
@@ -213,7 +214,10 @@ do-install:
fi) ; \
fi)
.if !defined(NOPORTDOCS)
- ${PERL} -pi -e "s:/home/httpd/html/horde/imp:${IMPDIR}:g" ${WRKSRC}/docs/SECURITY
+ ${REINPLACE_CMD} -e "s:/home/httpd/html/horde:${HORDEDIR}:g ; \
+ s:/home/httpd/horde-phplib:${HORDEDIR}/phplib:g ; \
+ s:nobody:www:g" \
+ ${WRKSRC}/docs/SECURITY
${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
@@ -248,6 +252,7 @@ post-install:
@${ECHO} "IMAP-UW; you may want to reinstall it with SSL support, or"
@${ECHO} "if you need an SSL connection to your IMAP server, you can"
@${ECHO} "install the port security/stunnel."
+ @${ECHO} "Note: without SSL, you have to choose the IMAP port 143/notls"
@${ECHO} "******************************************************************"
.include <bsd.port.mk>
diff --git a/mail/imp/Makefile b/mail/imp/Makefile
index 582d3ae84573..d71c04a3b821 100644
--- a/mail/imp/Makefile
+++ b/mail/imp/Makefile
@@ -93,6 +93,9 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/ispell:${PORTSDIR}/textproc/ispell
.endif
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeImp
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/DATABASE \
docs/HELP docs/INSTALL docs/SECURITY docs/KNOWN_BUGS \
docs/PACKAGES
@@ -173,19 +176,17 @@ do-install:
${CP} -Rp ${WRKSRC}/config ${WRKSRC}/graphics ${WRKSRC}/lib ${IMPDIR}
${CP} -Rp ${WRKSRC}/locale ${WRKSRC}/scripts ${WRKSRC}/templates ${IMPDIR}
${CP} -p ${WRKSRC}/*.php3 ${WRKSRC}/*.css ${IMPDIR}
- ${PERL} -pi -e "s:/usr/bin/ispell:${LOCALBASE}/bin/ispell:g" \
- ${IMPDIR}/config/defaults.php3.dist
- ${PERL} -pi -e "s:/usr/bin/wvHtml:${LOCALBASE}/bin/wvHtml:g" \
- ${IMPDIR}/config/defaults.php3.dist
- ${PERL} -pi -e "s:/usr/bin/xlHtml:${LOCALBASE}/bin/xlhtml:g" \
+ ${REINPLACE_CMD} -e "s:/usr/bin/ispell:${LOCALBASE}/bin/ispell:g ; \
+ s:/usr/bin/wvHtml:${LOCALBASE}/bin/wvHtml:g ; \
+ s:/usr/bin/xlHtml:${LOCALBASE}/bin/xlhtml:g ; \
+ s:/bin/tar:/usr/bin/tar:g ; \
+ s:/usr/bin/zipinfo:${LOCALBASE}/bin/zipinfo:g" \
${IMPDIR}/config/defaults.php3.dist
- ${PERL} -pi -e "s:/bin/tar:/usr/bin/tar:g" ${IMPDIR}/config/defaults.php3.dist
- ${PERL} -pi -e "s:/usr/bin/zipinfo:${LOCALBASE}/bin/zipinfo:g" \
- ${IMPDIR}/config/defaults.php3.dist
- ${PERL} -pi -e "s:sh ./secure.sh:${HORDESBIN}/horde_secure.sh:g" \
- ${IMPDIR}/templates/index/imp_notconfigured.inc
- ${PERL} -pi -e "s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" \
+ @${RM} ${IMPDIR}/config/defaults.php3.dist.beforeImp
+ ${REINPLACE_CMD} -e "s:sh ./secure.sh:${HORDESBIN}/horde_secure.sh:g ; \
+ s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" \
${IMPDIR}/templates/index/imp_notconfigured.inc
+ @${RM} ${IMPDIR}/templates/index/imp_notconfigured.inc.beforeImp
@if [ ! -f ${IMPDIR}/config/defaults.php3 ]; then \
${CP} ${IMPDIR}/config/defaults.php3.dist ${IMPDIR}/config/defaults.php3; \
fi
@@ -205,7 +206,7 @@ do-install:
(if [ ! -f ${APACHE_CONF}.beforeIMP ] ; then \
${ECHO} "===> Updating ${APACHE_CONF}..." ; \
${CP} -p ${.CURDIR}/httpd.conf.imp ${WRKDIR}/httpd.conf.imp ; \
- ${PERL} -pi -e "s:/home/httpd/html/horde/imp:${IMPDIR}:g" \
+ ${REINPLACE_CMD} -e "s:/home/httpd/html/horde/imp:${IMPDIR}:g" \
${WRKDIR}/httpd.conf.imp ; \
${CP} -p ${APACHE_CONF} ${APACHE_CONF}.beforeIMP ; \
${GREP} -qw 'Added for IMP' ${APACHE_CONF} || ${CAT} ${WRKDIR}/httpd.conf.imp \
@@ -213,7 +214,10 @@ do-install:
fi) ; \
fi)
.if !defined(NOPORTDOCS)
- ${PERL} -pi -e "s:/home/httpd/html/horde/imp:${IMPDIR}:g" ${WRKSRC}/docs/SECURITY
+ ${REINPLACE_CMD} -e "s:/home/httpd/html/horde:${HORDEDIR}:g ; \
+ s:/home/httpd/horde-phplib:${HORDEDIR}/phplib:g ; \
+ s:nobody:www:g" \
+ ${WRKSRC}/docs/SECURITY
${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
@@ -248,6 +252,7 @@ post-install:
@${ECHO} "IMAP-UW; you may want to reinstall it with SSL support, or"
@${ECHO} "if you need an SSL connection to your IMAP server, you can"
@${ECHO} "install the port security/stunnel."
+ @${ECHO} "Note: without SSL, you have to choose the IMAP port 143/notls"
@${ECHO} "******************************************************************"
.include <bsd.port.mk>
diff --git a/misc/libmcal/Makefile b/misc/libmcal/Makefile
index 0e02d634d1d4..063d2a90db7b 100644
--- a/misc/libmcal/Makefile
+++ b/misc/libmcal/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= ltdl.1:${PORTSDIR}/devel/libtool
HAS_CONFIGURE= yes
USE_LIBTOOL= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
CONFIGURE_ARGS= --with-mstore --with-icap \
--prefix=${PREFIX} --exec-prefix=${PREFIX}
INSTALLS_SHLIB= yes
@@ -43,7 +44,7 @@ post-extract:
${MV} ${WRKSRC}/mstore/README ${WRKSRC}/mstore/README.mstore
post-patch:
- ${PERL} -pi -e "s:/etc/mpasswd:${PREFIX}/etc/mpasswd:" ${WRKSRC}/mstore/mstore.c
+ ${REINPLACE_CMD} -e "s:/etc/mpasswd:${PREFIX}/etc/mpasswd:" ${WRKSRC}/mstore/mstore.c
pre-configure:
@${ECHO_MSG} "===> Building the driver mstore"
@@ -55,8 +56,10 @@ pre-configure:
post-install:
.if !defined(NOPORTDOCS)
- ${PERL} -pi -e "s:/etc/mpasswd:${LOCALBASE}/etc/mpasswd:" ${WRKSRC}/FAQ-MCAL
- ${PERL} -pi -e "s:/etc/mpasswd:${LOCALBASE}/etc/mpasswd:" ${WRKSRC}/mstore/README.mstore
+ ${REINPLACE_CMD} -e "s:/etc/mpasswd:${LOCALBASE}/etc/mpasswd:" \
+ ${WRKSRC}/FAQ-MCAL
+ ${REINPLACE_CMD} -e "s:/etc/mpasswd:${LOCALBASE}/etc/mpasswd:" \
+ ${WRKSRC}/mstore/README.mstore
${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
diff --git a/www/horde-base/Makefile b/www/horde-base/Makefile
index c002a5780460..c2ee3ac174b5 100644
--- a/www/horde-base/Makefile
+++ b/www/horde-base/Makefile
@@ -32,6 +32,9 @@ RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
.endif
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeHorde
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/DATABASE \
docs/HELP docs/INSTALL docs/SECURITY
@@ -89,23 +92,24 @@ do-install:
${CP} -Rp ${WRKSRC}/locale ${WRKSRC}/scripts ${WRKSRC}/templates ${HORDEDIR}
${CP} -p ${WRKSRC}/phplib/* ${PHPLIBDIR}
${CP} -p ${WRKSRC}/*.php3 ${HORDEDIR}
- ${CP} -p ${WRKSRC}/install.sh ${HORDESBIN}/horde_setup.sh
- ${CP} -p ${WRKSRC}/secure.sh ${HORDESBIN}/horde_secure.sh
- ${PERL} -pi -e "s:chmod 444 :chmod 444 ${HORDEDIR}/:g" ${HORDESBIN}/horde_secure.sh
- ${PERL} -pi -e "s:chmod 000 :chmod 000 ${HORDEDIR}/:g" ${HORDESBIN}/horde_secure.sh
- ${PERL} -pi -e "s:-d imp:-d ${HORDEDIR}/imp:g" ${HORDESBIN}/horde_setup.sh
- ${PERL} -pi -e "s:config/horde:${HORDEDIR}/config/horde:g" ${HORDESBIN}/horde_setup.sh
- ${PERL} -pi -e "s:imp/config:${HORDEDIR}/imp/config:g" ${HORDESBIN}/horde_setup.sh
- ${PERL} -pi -e "s:chmod 444 :chmod 444 ${HORDEDIR}/:g" ${HORDESBIN}/horde_setup.sh
+ ${REINPLACE_CMD} -e "s:-d imp:-d ${HORDEDIR}/imp:g ; \
+ s:config/horde:${HORDEDIR}/config/horde:g ; \
+ s:imp/config:${HORDEDIR}/imp/config:g ; \
+ s:chmod 444 :chmod 444 ${HORDEDIR}/:g" ${WRKSRC}/install.sh
+ ${CP} ${WRKSRC}/install.sh ${HORDESBIN}/horde_setup.sh
+ ${REINPLACE_CMD} -e "s:%%HORDEDIR%%:${HORDEDIR}:g" ${WRKSRC}/secure.sh
+ ${CP} ${WRKSRC}/secure.sh ${HORDESBIN}/horde_secure.sh
${CHMOD} u+x ${HORDESBIN}/horde_secure.sh
${CHMOD} u+x ${HORDESBIN}/horde_setup.sh
- ${PERL} -pi -e "s:go to the top level directory for your installation and run:run:g" \
- ${HORDEDIR}/setup.php3
- ${PERL} -pi -e "s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" ${HORDEDIR}/setup.php3
- ${PERL} -pi -e "s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" \
+ ${REINPLACE_CMD} -e "s:go to the top level directory for your installation and run:run:g ; \
+ s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" ${HORDEDIR}/setup.php3
+ @${RM} ${HORDEDIR}/setup.php3.beforeHorde
+ ${REINPLACE_CMD} -e "s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" \
${HORDEDIR}/templates/index/horde_notconfigured.inc
- ${PERL} -pi -e "s:sh ./secure.sh:${HORDESBIN}/horde_secure.sh:g" \
+ @${RM} ${HORDEDIR}/templates/index/horde_notconfigured.inc.beforeHorde
+ ${REINPLACE_CMD} -e "s:sh ./secure.sh:${HORDESBIN}/horde_secure.sh:g" \
${HORDEDIR}/templates/setup/imp/write_file.inc
+ @${RM} ${HORDEDIR}/templates/setup/imp/write_file.inc.beforeHorde
${CP} ${HORDEDIR}/config/horde.php3.dist ${HORDEDIR}/config/horde.php3
${CHMOD} 444 ${HORDEDIR}/config/horde.php3
${CHMOD} 444 ${HORDEDIR}/setup.php3
@@ -129,8 +133,8 @@ do-install:
(if [ ! -f ${APACHE_CONF}.beforeHorde ] ; then \
${ECHO} "===> Updating httpd.conf..." ; \
${CP} -p ${MASTERDIR}/httpd.conf.phplib ${WRKDIR}/httpd.conf.phplib ; \
- ${PERL} -pi -e "s:/home/httpd/html/horde:${HORDEDIR}:g" ${WRKDIR}/httpd.conf.phplib ; \
- ${PERL} -pi -e "s:/home/httpd/phplib:${PHPLIBDIR}:g" ${WRKDIR}/httpd.conf.phplib ; \
+ ${REINPLACE_CMD} -e "s:/home/httpd/html/horde:${HORDEDIR}:g ; \
+ s:/home/httpd/phplib:${PHPLIBDIR}:g" ${WRKDIR}/httpd.conf.phplib ; \
${CP} -p ${APACHE_CONF} ${APACHE_CONF}.beforeHorde ; \
${GREP} -qw 'phplib' ${APACHE_CONF} || ${CAT} ${WRKDIR}/httpd.conf.phplib >> ${APACHE_CONF} ; \
fi) ; \
@@ -141,8 +145,9 @@ do-install:
fi
@if ! ${GREP} -q -e '^upload_tmp_dir' ${PHP_INI} ; then \
${ECHO_MSG} "===> Configuring ${PHP_INI} for imp" ; \
- ${CP} -p ${PHP_INI} ${PHP_INI}.beforeHorde1 ; \
- ${PERL} -pi -e 's!;upload_tmp_dir =!upload_tmp_dir = /tmp!' ${PHP_INI} ; \
+ ${REINPLACE_CMD} -e 's!;upload_tmp_dir =!upload_tmp_dir = /tmp!' \
+ ${PHP_INI} ; \
+ ${MV} ${PHP_INI}.beforeHorde ${PHP_INI}.beforeHorde1 ; \
fi
${CHOWN} -R www:www ${HORDEDIR}
.if !defined(NOPORTDOCS)
diff --git a/www/horde-base/files/patch-secure.sh b/www/horde-base/files/patch-secure.sh
new file mode 100644
index 000000000000..49e97c6c2b92
--- /dev/null
+++ b/www/horde-base/files/patch-secure.sh
@@ -0,0 +1,28 @@
+--- secure.sh.orig Sun May 28 05:09:52 2000
++++ secure.sh Sun Jul 7 11:37:19 2002
+@@ -1,17 +1,17 @@
+ #!/bin/sh
+
+ # Horde Items
+-chmod 444 config/horde.php3 > /dev/null 2> /dev/null
+-chmod 444 lib/horde.lib > /dev/null 2> /dev/null
+-chmod 444 lib/mime.lib > /dev/null 2> /dev/null
++chmod 444 %%HORDEDIR%%/config/horde.php3 > /dev/null 2> /dev/null
++chmod 444 %%HORDEDIR%%/lib/horde.lib > /dev/null 2> /dev/null
++chmod 444 %%HORDEDIR%%/lib/mime.lib > /dev/null 2> /dev/null
+
+ # IMP Items
+-chmod 444 imp/config/defaults.php3 > /dev/null 2> /dev/null
+-chmod 444 imp/lib/imp.lib > /dev/null 2> /dev/null
+-chmod 444 imp/lib/mimetypes.lib > /dev/null 2> /dev/null
++chmod 444 %%HORDEDIR%%/imp/config/defaults.php3 > /dev/null 2> /dev/null
++chmod 444 %%HORDEDIR%%/imp/lib/imp.lib > /dev/null 2> /dev/null
++chmod 444 %%HORDEDIR%%/imp/lib/mimetypes.lib > /dev/null 2> /dev/null
+
+-chmod 000 setup.php3 > /dev/null 2> /dev/null
+-chmod 000 test.php3 > /dev/null 2> /dev/null
++chmod 000 %%HORDEDIR%%/setup.php3 > /dev/null 2> /dev/null
++chmod 000 %%HORDEDIR%%/test.php3 > /dev/null 2> /dev/null
+
+ echo
+ echo I have made your configuration files, and libraries mode 0444
diff --git a/www/horde/Makefile b/www/horde/Makefile
index c002a5780460..c2ee3ac174b5 100644
--- a/www/horde/Makefile
+++ b/www/horde/Makefile
@@ -32,6 +32,9 @@ RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
.endif
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeHorde
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/DATABASE \
docs/HELP docs/INSTALL docs/SECURITY
@@ -89,23 +92,24 @@ do-install:
${CP} -Rp ${WRKSRC}/locale ${WRKSRC}/scripts ${WRKSRC}/templates ${HORDEDIR}
${CP} -p ${WRKSRC}/phplib/* ${PHPLIBDIR}
${CP} -p ${WRKSRC}/*.php3 ${HORDEDIR}
- ${CP} -p ${WRKSRC}/install.sh ${HORDESBIN}/horde_setup.sh
- ${CP} -p ${WRKSRC}/secure.sh ${HORDESBIN}/horde_secure.sh
- ${PERL} -pi -e "s:chmod 444 :chmod 444 ${HORDEDIR}/:g" ${HORDESBIN}/horde_secure.sh
- ${PERL} -pi -e "s:chmod 000 :chmod 000 ${HORDEDIR}/:g" ${HORDESBIN}/horde_secure.sh
- ${PERL} -pi -e "s:-d imp:-d ${HORDEDIR}/imp:g" ${HORDESBIN}/horde_setup.sh
- ${PERL} -pi -e "s:config/horde:${HORDEDIR}/config/horde:g" ${HORDESBIN}/horde_setup.sh
- ${PERL} -pi -e "s:imp/config:${HORDEDIR}/imp/config:g" ${HORDESBIN}/horde_setup.sh
- ${PERL} -pi -e "s:chmod 444 :chmod 444 ${HORDEDIR}/:g" ${HORDESBIN}/horde_setup.sh
+ ${REINPLACE_CMD} -e "s:-d imp:-d ${HORDEDIR}/imp:g ; \
+ s:config/horde:${HORDEDIR}/config/horde:g ; \
+ s:imp/config:${HORDEDIR}/imp/config:g ; \
+ s:chmod 444 :chmod 444 ${HORDEDIR}/:g" ${WRKSRC}/install.sh
+ ${CP} ${WRKSRC}/install.sh ${HORDESBIN}/horde_setup.sh
+ ${REINPLACE_CMD} -e "s:%%HORDEDIR%%:${HORDEDIR}:g" ${WRKSRC}/secure.sh
+ ${CP} ${WRKSRC}/secure.sh ${HORDESBIN}/horde_secure.sh
${CHMOD} u+x ${HORDESBIN}/horde_secure.sh
${CHMOD} u+x ${HORDESBIN}/horde_setup.sh
- ${PERL} -pi -e "s:go to the top level directory for your installation and run:run:g" \
- ${HORDEDIR}/setup.php3
- ${PERL} -pi -e "s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" ${HORDEDIR}/setup.php3
- ${PERL} -pi -e "s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" \
+ ${REINPLACE_CMD} -e "s:go to the top level directory for your installation and run:run:g ; \
+ s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" ${HORDEDIR}/setup.php3
+ @${RM} ${HORDEDIR}/setup.php3.beforeHorde
+ ${REINPLACE_CMD} -e "s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" \
${HORDEDIR}/templates/index/horde_notconfigured.inc
- ${PERL} -pi -e "s:sh ./secure.sh:${HORDESBIN}/horde_secure.sh:g" \
+ @${RM} ${HORDEDIR}/templates/index/horde_notconfigured.inc.beforeHorde
+ ${REINPLACE_CMD} -e "s:sh ./secure.sh:${HORDESBIN}/horde_secure.sh:g" \
${HORDEDIR}/templates/setup/imp/write_file.inc
+ @${RM} ${HORDEDIR}/templates/setup/imp/write_file.inc.beforeHorde
${CP} ${HORDEDIR}/config/horde.php3.dist ${HORDEDIR}/config/horde.php3
${CHMOD} 444 ${HORDEDIR}/config/horde.php3
${CHMOD} 444 ${HORDEDIR}/setup.php3
@@ -129,8 +133,8 @@ do-install:
(if [ ! -f ${APACHE_CONF}.beforeHorde ] ; then \
${ECHO} "===> Updating httpd.conf..." ; \
${CP} -p ${MASTERDIR}/httpd.conf.phplib ${WRKDIR}/httpd.conf.phplib ; \
- ${PERL} -pi -e "s:/home/httpd/html/horde:${HORDEDIR}:g" ${WRKDIR}/httpd.conf.phplib ; \
- ${PERL} -pi -e "s:/home/httpd/phplib:${PHPLIBDIR}:g" ${WRKDIR}/httpd.conf.phplib ; \
+ ${REINPLACE_CMD} -e "s:/home/httpd/html/horde:${HORDEDIR}:g ; \
+ s:/home/httpd/phplib:${PHPLIBDIR}:g" ${WRKDIR}/httpd.conf.phplib ; \
${CP} -p ${APACHE_CONF} ${APACHE_CONF}.beforeHorde ; \
${GREP} -qw 'phplib' ${APACHE_CONF} || ${CAT} ${WRKDIR}/httpd.conf.phplib >> ${APACHE_CONF} ; \
fi) ; \
@@ -141,8 +145,9 @@ do-install:
fi
@if ! ${GREP} -q -e '^upload_tmp_dir' ${PHP_INI} ; then \
${ECHO_MSG} "===> Configuring ${PHP_INI} for imp" ; \
- ${CP} -p ${PHP_INI} ${PHP_INI}.beforeHorde1 ; \
- ${PERL} -pi -e 's!;upload_tmp_dir =!upload_tmp_dir = /tmp!' ${PHP_INI} ; \
+ ${REINPLACE_CMD} -e 's!;upload_tmp_dir =!upload_tmp_dir = /tmp!' \
+ ${PHP_INI} ; \
+ ${MV} ${PHP_INI}.beforeHorde ${PHP_INI}.beforeHorde1 ; \
fi
${CHOWN} -R www:www ${HORDEDIR}
.if !defined(NOPORTDOCS)
diff --git a/www/horde/files/patch-secure.sh b/www/horde/files/patch-secure.sh
new file mode 100644
index 000000000000..49e97c6c2b92
--- /dev/null
+++ b/www/horde/files/patch-secure.sh
@@ -0,0 +1,28 @@
+--- secure.sh.orig Sun May 28 05:09:52 2000
++++ secure.sh Sun Jul 7 11:37:19 2002
+@@ -1,17 +1,17 @@
+ #!/bin/sh
+
+ # Horde Items
+-chmod 444 config/horde.php3 > /dev/null 2> /dev/null
+-chmod 444 lib/horde.lib > /dev/null 2> /dev/null
+-chmod 444 lib/mime.lib > /dev/null 2> /dev/null
++chmod 444 %%HORDEDIR%%/config/horde.php3 > /dev/null 2> /dev/null
++chmod 444 %%HORDEDIR%%/lib/horde.lib > /dev/null 2> /dev/null
++chmod 444 %%HORDEDIR%%/lib/mime.lib > /dev/null 2> /dev/null
+
+ # IMP Items
+-chmod 444 imp/config/defaults.php3 > /dev/null 2> /dev/null
+-chmod 444 imp/lib/imp.lib > /dev/null 2> /dev/null
+-chmod 444 imp/lib/mimetypes.lib > /dev/null 2> /dev/null
++chmod 444 %%HORDEDIR%%/imp/config/defaults.php3 > /dev/null 2> /dev/null
++chmod 444 %%HORDEDIR%%/imp/lib/imp.lib > /dev/null 2> /dev/null
++chmod 444 %%HORDEDIR%%/imp/lib/mimetypes.lib > /dev/null 2> /dev/null
+
+-chmod 000 setup.php3 > /dev/null 2> /dev/null
+-chmod 000 test.php3 > /dev/null 2> /dev/null
++chmod 000 %%HORDEDIR%%/setup.php3 > /dev/null 2> /dev/null
++chmod 000 %%HORDEDIR%%/test.php3 > /dev/null 2> /dev/null
+
+ echo
+ echo I have made your configuration files, and libraries mode 0444
diff --git a/www/horde4-base/Makefile b/www/horde4-base/Makefile
index c002a5780460..c2ee3ac174b5 100644
--- a/www/horde4-base/Makefile
+++ b/www/horde4-base/Makefile
@@ -32,6 +32,9 @@ RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
.endif
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeHorde
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/DATABASE \
docs/HELP docs/INSTALL docs/SECURITY
@@ -89,23 +92,24 @@ do-install:
${CP} -Rp ${WRKSRC}/locale ${WRKSRC}/scripts ${WRKSRC}/templates ${HORDEDIR}
${CP} -p ${WRKSRC}/phplib/* ${PHPLIBDIR}
${CP} -p ${WRKSRC}/*.php3 ${HORDEDIR}
- ${CP} -p ${WRKSRC}/install.sh ${HORDESBIN}/horde_setup.sh
- ${CP} -p ${WRKSRC}/secure.sh ${HORDESBIN}/horde_secure.sh
- ${PERL} -pi -e "s:chmod 444 :chmod 444 ${HORDEDIR}/:g" ${HORDESBIN}/horde_secure.sh
- ${PERL} -pi -e "s:chmod 000 :chmod 000 ${HORDEDIR}/:g" ${HORDESBIN}/horde_secure.sh
- ${PERL} -pi -e "s:-d imp:-d ${HORDEDIR}/imp:g" ${HORDESBIN}/horde_setup.sh
- ${PERL} -pi -e "s:config/horde:${HORDEDIR}/config/horde:g" ${HORDESBIN}/horde_setup.sh
- ${PERL} -pi -e "s:imp/config:${HORDEDIR}/imp/config:g" ${HORDESBIN}/horde_setup.sh
- ${PERL} -pi -e "s:chmod 444 :chmod 444 ${HORDEDIR}/:g" ${HORDESBIN}/horde_setup.sh
+ ${REINPLACE_CMD} -e "s:-d imp:-d ${HORDEDIR}/imp:g ; \
+ s:config/horde:${HORDEDIR}/config/horde:g ; \
+ s:imp/config:${HORDEDIR}/imp/config:g ; \
+ s:chmod 444 :chmod 444 ${HORDEDIR}/:g" ${WRKSRC}/install.sh
+ ${CP} ${WRKSRC}/install.sh ${HORDESBIN}/horde_setup.sh
+ ${REINPLACE_CMD} -e "s:%%HORDEDIR%%:${HORDEDIR}:g" ${WRKSRC}/secure.sh
+ ${CP} ${WRKSRC}/secure.sh ${HORDESBIN}/horde_secure.sh
${CHMOD} u+x ${HORDESBIN}/horde_secure.sh
${CHMOD} u+x ${HORDESBIN}/horde_setup.sh
- ${PERL} -pi -e "s:go to the top level directory for your installation and run:run:g" \
- ${HORDEDIR}/setup.php3
- ${PERL} -pi -e "s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" ${HORDEDIR}/setup.php3
- ${PERL} -pi -e "s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" \
+ ${REINPLACE_CMD} -e "s:go to the top level directory for your installation and run:run:g ; \
+ s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" ${HORDEDIR}/setup.php3
+ @${RM} ${HORDEDIR}/setup.php3.beforeHorde
+ ${REINPLACE_CMD} -e "s:sh ./install.sh:${HORDESBIN}/horde_setup.sh:g" \
${HORDEDIR}/templates/index/horde_notconfigured.inc
- ${PERL} -pi -e "s:sh ./secure.sh:${HORDESBIN}/horde_secure.sh:g" \
+ @${RM} ${HORDEDIR}/templates/index/horde_notconfigured.inc.beforeHorde
+ ${REINPLACE_CMD} -e "s:sh ./secure.sh:${HORDESBIN}/horde_secure.sh:g" \
${HORDEDIR}/templates/setup/imp/write_file.inc
+ @${RM} ${HORDEDIR}/templates/setup/imp/write_file.inc.beforeHorde
${CP} ${HORDEDIR}/config/horde.php3.dist ${HORDEDIR}/config/horde.php3
${CHMOD} 444 ${HORDEDIR}/config/horde.php3
${CHMOD} 444 ${HORDEDIR}/setup.php3
@@ -129,8 +133,8 @@ do-install:
(if [ ! -f ${APACHE_CONF}.beforeHorde ] ; then \
${ECHO} "===> Updating httpd.conf..." ; \
${CP} -p ${MASTERDIR}/httpd.conf.phplib ${WRKDIR}/httpd.conf.phplib ; \
- ${PERL} -pi -e "s:/home/httpd/html/horde:${HORDEDIR}:g" ${WRKDIR}/httpd.conf.phplib ; \
- ${PERL} -pi -e "s:/home/httpd/phplib:${PHPLIBDIR}:g" ${WRKDIR}/httpd.conf.phplib ; \
+ ${REINPLACE_CMD} -e "s:/home/httpd/html/horde:${HORDEDIR}:g ; \
+ s:/home/httpd/phplib:${PHPLIBDIR}:g" ${WRKDIR}/httpd.conf.phplib ; \
${CP} -p ${APACHE_CONF} ${APACHE_CONF}.beforeHorde ; \
${GREP} -qw 'phplib' ${APACHE_CONF} || ${CAT} ${WRKDIR}/httpd.conf.phplib >> ${APACHE_CONF} ; \
fi) ; \
@@ -141,8 +145,9 @@ do-install:
fi
@if ! ${GREP} -q -e '^upload_tmp_dir' ${PHP_INI} ; then \
${ECHO_MSG} "===> Configuring ${PHP_INI} for imp" ; \
- ${CP} -p ${PHP_INI} ${PHP_INI}.beforeHorde1 ; \
- ${PERL} -pi -e 's!;upload_tmp_dir =!upload_tmp_dir = /tmp!' ${PHP_INI} ; \
+ ${REINPLACE_CMD} -e 's!;upload_tmp_dir =!upload_tmp_dir = /tmp!' \
+ ${PHP_INI} ; \
+ ${MV} ${PHP_INI}.beforeHorde ${PHP_INI}.beforeHorde1 ; \
fi
${CHOWN} -R www:www ${HORDEDIR}
.if !defined(NOPORTDOCS)
diff --git a/www/horde4-base/files/patch-secure.sh b/www/horde4-base/files/patch-secure.sh
new file mode 100644
index 000000000000..49e97c6c2b92
--- /dev/null
+++ b/www/horde4-base/files/patch-secure.sh
@@ -0,0 +1,28 @@
+--- secure.sh.orig Sun May 28 05:09:52 2000
++++ secure.sh Sun Jul 7 11:37:19 2002
+@@ -1,17 +1,17 @@
+ #!/bin/sh
+
+ # Horde Items
+-chmod 444 config/horde.php3 > /dev/null 2> /dev/null
+-chmod 444 lib/horde.lib > /dev/null 2> /dev/null
+-chmod 444 lib/mime.lib > /dev/null 2> /dev/null
++chmod 444 %%HORDEDIR%%/config/horde.php3 > /dev/null 2> /dev/null
++chmod 444 %%HORDEDIR%%/lib/horde.lib > /dev/null 2> /dev/null
++chmod 444 %%HORDEDIR%%/lib/mime.lib > /dev/null 2> /dev/null
+
+ # IMP Items
+-chmod 444 imp/config/defaults.php3 > /dev/null 2> /dev/null
+-chmod 444 imp/lib/imp.lib > /dev/null 2> /dev/null
+-chmod 444 imp/lib/mimetypes.lib > /dev/null 2> /dev/null
++chmod 444 %%HORDEDIR%%/imp/config/defaults.php3 > /dev/null 2> /dev/null
++chmod 444 %%HORDEDIR%%/imp/lib/imp.lib > /dev/null 2> /dev/null
++chmod 444 %%HORDEDIR%%/imp/lib/mimetypes.lib > /dev/null 2> /dev/null
+
+-chmod 000 setup.php3 > /dev/null 2> /dev/null
+-chmod 000 test.php3 > /dev/null 2> /dev/null
++chmod 000 %%HORDEDIR%%/setup.php3 > /dev/null 2> /dev/null
++chmod 000 %%HORDEDIR%%/test.php3 > /dev/null 2> /dev/null
+
+ echo
+ echo I have made your configuration files, and libraries mode 0444