summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2007-04-14 14:41:53 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2007-04-14 14:41:53 +0000
commit1e06305cee2a644e3da6860829f28ef0228803f9 (patch)
treef1cc7f550592cd8692d15dd58da530e9851c6e06
parentUpdate to the 20070413 snapshot of GCC 4.3.0. (diff)
- Update to 1.4.15
PR: 111552 Submitted by: Gea-Suan Lin <gslin___gslin.org>
-rw-r--r--www/lighttpd/Makefile7
-rw-r--r--www/lighttpd/distinfo6
-rw-r--r--www/lighttpd/files/patch-src__connections.c11
-rw-r--r--www/lighttpd/files/patch-src__mod_cgi.c18
-rw-r--r--www/lighttpd/files/patch-src__mod_webdav.c18
-rw-r--r--www/lighttpd/pkg-plist3
6 files changed, 9 insertions, 54 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 385c8fa997f0..6e6d1f899a0b 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= lighttpd
-PORTVERSION= 1.4.13
-PORTREVISION= 2
+PORTVERSION= 1.4.15
CATEGORIES= www
MASTER_SITES= http://www.lighttpd.net/download/ \
http://mirrors.cat.pdx.edu/lighttpd/
@@ -17,11 +16,11 @@ COMMENT= A secure, fast, compliant, and very flexible Web Server
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
-USE_AUTOTOOLS= autoconf:259 libtool:15
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_GNOME= lthack
USE_RC_SUBR= lighttpd.sh
-CONFIGURE_ARGS= --libdir=${PREFIX}/lib/lighttpd
+CONFIGURE_ARGS= --libdir=${PREFIX}/lib/lighttpd --mandir=${PREFIX}/man
CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/www/lighttpd/distinfo b/www/lighttpd/distinfo
index 907f7a388240..7bbac6324b71 100644
--- a/www/lighttpd/distinfo
+++ b/www/lighttpd/distinfo
@@ -1,3 +1,3 @@
-MD5 (lighttpd-1.4.13.tar.gz) = d775d6478391b95d841a1018c8db0b95
-SHA256 (lighttpd-1.4.13.tar.gz) = 62d5997fdb41afa9400adcdb040d04a1f5fa950045df96e3e3f593e8f0de5739
-SIZE (lighttpd-1.4.13.tar.gz) = 797813
+MD5 (lighttpd-1.4.15.tar.gz) = d2ceaaf242b2b3593ff4d8222d543649
+SHA256 (lighttpd-1.4.15.tar.gz) = 7eecd4f9a3b19f4ef5e4d4b4b9635abb699ee6abfc08f029e5df1234670e1831
+SIZE (lighttpd-1.4.15.tar.gz) = 794327
diff --git a/www/lighttpd/files/patch-src__connections.c b/www/lighttpd/files/patch-src__connections.c
deleted file mode 100644
index 56f4243218e0..000000000000
--- a/www/lighttpd/files/patch-src__connections.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/connections.c.orig 2007-01-05 10:56:08.000000000 -0800
-+++ src/connections.c 2007-01-05 10:56:23.000000000 -0800
-@@ -970,7 +970,7 @@
- }
- } else {
- /* a splited \r \n */
-- return -1;
-+ break;
- }
- }
- }
diff --git a/www/lighttpd/files/patch-src__mod_cgi.c b/www/lighttpd/files/patch-src__mod_cgi.c
deleted file mode 100644
index 11804920f657..000000000000
--- a/www/lighttpd/files/patch-src__mod_cgi.c
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# http://trac.lighttpd.net/trac/ticket/861
-#
---- src/mod_cgi.c.orig Mon Mar 26 09:25:21 2007
-+++ src/mod_cgi.c Mon Mar 26 09:27:23 2007
-@@ -842,6 +842,12 @@
- CONST_BUF_LEN(con->authed_user));
- }
-
-+#ifdef USE_OPENSSL
-+ if (srv_sock->is_ssl) {
-+ cgi_env_add(&env, CONST_STR_LEN("HTTPS"), CONST_STR_LEN("on"));
-+ }
-+#endif
-+
- /* request.content_length < SSIZE_MAX, see request.c */
- ltostr(buf, con->request.content_length);
- cgi_env_add(&env, CONST_STR_LEN("CONTENT_LENGTH"), buf, strlen(buf));
diff --git a/www/lighttpd/files/patch-src__mod_webdav.c b/www/lighttpd/files/patch-src__mod_webdav.c
deleted file mode 100644
index e8176d65b38e..000000000000
--- a/www/lighttpd/files/patch-src__mod_webdav.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/mod_webdav.c.orig Tue Oct 10 01:08:09 2006
-+++ src/mod_webdav.c Tue Oct 10 01:09:02 2006
-@@ -1151,11 +1151,13 @@
- *
- */
- int webdav_has_lock(server *srv, connection *con, plugin_data *p, buffer *uri) {
-- UNUSED(srv);
- int has_lock = 1;
--
- #ifdef USE_LOCKS
- data_string *ds;
-+#endif
-+ UNUSED(srv);
-+
-+#ifdef USE_LOCKS
-
- /**
- * This implementation is more fake than real
diff --git a/www/lighttpd/pkg-plist b/www/lighttpd/pkg-plist
index e8d15f40c041..eadb19610c08 100644
--- a/www/lighttpd/pkg-plist
+++ b/www/lighttpd/pkg-plist
@@ -36,6 +36,9 @@ lib/lighttpd/mod_evhost.so
lib/lighttpd/mod_expire.a
lib/lighttpd/mod_expire.la
lib/lighttpd/mod_expire.so
+lib/lighttpd/mod_extforward.a
+lib/lighttpd/mod_extforward.la
+lib/lighttpd/mod_extforward.so
lib/lighttpd/mod_fastcgi.a
lib/lighttpd/mod_fastcgi.la
lib/lighttpd/mod_fastcgi.so