summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2008-09-04 10:17:05 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2008-09-04 10:17:05 +0000
commit1c9d8e43ae2d388c8b4e25f9ee55bbe7294af814 (patch)
tree81d78dbf5ce8d00ab39be90e15cbf27910f21b55
parent- Update to 2.2.4 (diff)
Update to version 2.5.
PR: 127028 Submitted by: Yi-Jheng Lin <yzlin@cs.nctu.edu.tw>
-rw-r--r--net/clusterit/Makefile21
-rw-r--r--net/clusterit/distinfo6
-rw-r--r--net/clusterit/files/patch-alignstring121
-rw-r--r--net/clusterit/files/patch-barrier::barrierd.c11
-rw-r--r--net/clusterit/files/patch-common::common.c34
-rw-r--r--net/clusterit/files/patch-dsh-dsh.c34
-rw-r--r--net/clusterit/files/patch-tools::dshbak.src24
-rw-r--r--net/clusterit/pkg-plist3
8 files changed, 13 insertions, 241 deletions
diff --git a/net/clusterit/Makefile b/net/clusterit/Makefile
index 009351dce5a1..66a953a35f8b 100644
--- a/net/clusterit/Makefile
+++ b/net/clusterit/Makefile
@@ -6,17 +6,18 @@
#
PORTNAME= clusterit
-PORTVERSION= 2.0
-PORTREVISION= 4
+PORTVERSION= 2.5
CATEGORIES= net devel parallel
-MASTER_SITES= http://www.garbled.net/download/ \
- ftp://ftp.chg.ru/pub/prog/parallel/clusterit/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= demon@FreeBSD.org
COMMENT= A collection of clustering tools
-MAN1= barrier.1 barrierd.1 dsh.1 jsh.1 jsd.1 \
- clustersed.1 run.1 seq.1 dshbak.1 pcp.1 pdf.1 prm.1
+GNU_CONFIGURE= yes
+
+MAN1= barrier.1 barrierd.1 clustersed.1 dsh.1 dshbak.1 \
+ dtop.1 jsh.1 jsd.1 pcp.1 pdf.1 prm.1 rseq.1 run.1
.if defined (WITHOUT_X11)
PLIST_SUB+= X11='@comment '
@@ -25,16 +26,10 @@ PLIST_SUB+= X11=''
MAN1+= rvt.1 dvt.1
USE_XORG= x11
.endif
-USE_PERL5_BUILD=yes
post-patch:
- @${FIND} ${WRKSRC} -name Makefile | ${XARGS} \
- ${PERL} -pi -e 's#/usr/X11R6#${LOCALBASE}#g'
-.for file in command.c rvt.c screen.c
- @${PERL} -pi -e "s/malloc.h/stdlib.h/g" ${WRKSRC}/rvt/${file}
-.endfor
.if defined(WITHOUT_X11)
- @${PERL} -pi -e 's#rvt dvt##g' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -E 's,^(SUBDIRS) = .*,\1 = barrier dsh jsd pcp dtop tools,' ${WRKSRC}/Makefile.in
.endif
.include <bsd.port.mk>
diff --git a/net/clusterit/distinfo b/net/clusterit/distinfo
index 4c72be24248e..843340a90cb0 100644
--- a/net/clusterit/distinfo
+++ b/net/clusterit/distinfo
@@ -1,3 +1,3 @@
-MD5 (clusterit-2.0.tar.gz) = 4868fdb108473c9ba3fef38450423469
-SHA256 (clusterit-2.0.tar.gz) = 5eec53f6834dcabfb78c24d00114fa18f0e216b3402b7e660fe9b78f223afd3d
-SIZE (clusterit-2.0.tar.gz) = 124564
+MD5 (clusterit-2.5.tar.gz) = f0e772e07122e388de629fb57f7237ab
+SHA256 (clusterit-2.5.tar.gz) = e50597fb361d9aefff0250108900a3837a4a14c46083d6eb5ed5d7fc42ce9f35
+SIZE (clusterit-2.5.tar.gz) = 295347
diff --git a/net/clusterit/files/patch-alignstring b/net/clusterit/files/patch-alignstring
deleted file mode 100644
index 4c4d9b125229..000000000000
--- a/net/clusterit/files/patch-alignstring
+++ /dev/null
@@ -1,121 +0,0 @@
-diff -ru clusterit-2.0/common/common.c clusterit-2.0-new/common/common.c
---- common/common.c Sat Apr 5 17:01:50 2003
-+++ common/common.c Sat Apr 5 16:56:15 2003
-@@ -316,24 +316,6 @@
-
- #endif /* CLUSTERS */
-
--/* return a string, followed by n - strlen spaces */
--
--char *
--alignstring(string, n)
-- char *string;
-- size_t n;
--{
-- size_t i;
-- char *newstring;
--
-- newstring = strdup(string);
-- for (i=1; i <= n - strlen(string); i++)
-- newstring = strcat(newstring, " ");
--
-- return(newstring);
--}
--
--
- /*
- * Simple error handling routine, needs severe work.
- * Its almost totally useless.
-diff -ru clusterit-2.0/common/common.h clusterit-2.0-new/common/common.h
---- common/common.h Tue Aug 14 04:21:39 2001
-+++ common/common.h Sat Apr 5 16:56:32 2003
-@@ -78,7 +78,6 @@
- typedef struct group_data group_t;
-
- void bailout __P((int));
--char *alignstring __P((char *, size_t));
- #ifndef __NetBSD__
- char * strsep(char **stringp, const char *delim);
- #endif
-diff -ru clusterit-2.0/dsh/dsh.c clusterit-2.0-new/dsh/dsh.c
---- dsh/dsh.c Tue Aug 14 04:21:38 2001
-+++ dsh/dsh.c Sat Apr 5 16:58:38 2003
-@@ -399,8 +399,8 @@
- bailout(__LINE__);
- while ((cd = fgets(pipebuf, sizeof(pipebuf), fd))) {
- if (cd != NULL)
-- (void)printf("%s: %s",
-- alignstring(nodeptr->name, maxnodelen), cd);
-+ (void)printf("%*s: %s",
-+ -maxnodelen, nodeptr->name, cd);
- }
- fclose(fd);
- fd = fdopen(nodeptr->err.fds[0], "r"); /* stderr */
-@@ -408,8 +408,8 @@
- bailout(__LINE__);
- while ((cd = fgets(pipebuf, sizeof(pipebuf), fd))) {
- if (errorflag && cd != NULL)
-- (void)printf("%s: %s",
-- alignstring(nodeptr->name, maxnodelen), cd);
-+ (void)printf("%*s: %s",
-+ -maxnodelen, nodeptr->name, cd);
- }
- fclose(fd);
- (void)wait(&status);
-diff -ru clusterit-2.0/dsh/run.c clusterit-2.0-new/dsh/run.c
---- dsh/run.c Tue Aug 14 04:21:38 2001
-+++ dsh/run.c Sat Apr 5 16:59:35 2003
-@@ -326,13 +326,12 @@
- bailout(__LINE__);
- fd = fdopen(nodeptr->out.fds[0], "r"); /* stdout */
- while ((p = fgets(buf, sizeof(buf), fd)))
-- (void)printf("%s: %s", alignstring(nodeptr->name, maxnodelen), p);
-+ (void)printf("%*s: %s", -maxnodelen, nodeptr->name, p);
- fclose(fd);
- fd = fdopen(nodeptr->err.fds[0], "r"); /* stderr */
- while ((p = fgets(buf, sizeof(buf), fd)))
- if (errorflag)
-- (void)printf("%s: %s",
-- alignstring(nodeptr->name, maxnodelen), p);
-+ (void)printf("%*s: %s", -maxnodelen, nodeptr->name, p);
- fclose(fd);
- (void)wait(&status);
- if (piping) {
-diff -ru clusterit-2.0/dvt/dvt.c clusterit-2.0-new/dvt/dvt.c
---- dvt/dvt.c Tue Aug 14 04:21:37 2001
-+++ dvt/dvt.c Sat Apr 5 17:00:07 2003
-@@ -610,8 +610,8 @@
- bailout(__LINE__);
- while ((cd = fgets(pipebuf, sizeof(pipebuf), fd))) {
- if (errorflag && cd != NULL)
-- (void)printf("ERROR %s: %s",
-- alignstring(nodeptr->name, maxnodelen), cd);
-+ (void)printf("ERROR %*s: %s",
-+ -maxnodelen, nodeptr->name, cd);
- }
- fclose(fd);
- (void)waitpid(nodeptr->childpid, &status, 0);
-diff -ru clusterit-2.0/pcp/pcp.c clusterit-2.0-new/pcp/pcp.c
---- pcp/pcp.c Tue Aug 14 04:21:34 2001
-+++ pcp/pcp.c Sat Apr 5 16:58:00 2003
-@@ -383,16 +383,16 @@
- bailout(__LINE__);
- while ((cd = fgets(pipebuf, sizeof(pipebuf), fd)))
- if (cd != NULL && !quiet)
-- (void)printf("%s: %s",
-- alignstring(nodeptr->name, maxnodelen), cd);
-+ (void)printf("%*s: %s",
-+ -maxnodelen, nodeptr->name, cd);
- fclose(fd);
- fd = fdopen(nodeptr->err.fds[0], "r"); /* stderr */
- if (fd == NULL)
- bailout(__LINE__);
- while ((cd = fgets(pipebuf, sizeof(pipebuf), fd)))
- if (cd != NULL && !quiet)
-- (void)printf("%s: %s",
-- alignstring(nodeptr->name, maxnodelen), cd);
-+ (void)printf("%*s: %s",
-+ -maxnodelen, nodeptr->name, cd);
- fclose(fd);
- (void)wait(&status);
- nodeptr = nodeptr->next;
diff --git a/net/clusterit/files/patch-barrier::barrierd.c b/net/clusterit/files/patch-barrier::barrierd.c
deleted file mode 100644
index 2355e02d0947..000000000000
--- a/net/clusterit/files/patch-barrier::barrierd.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- barrier/barrierd.c.orig Sat Oct 18 14:05:14 2003
-+++ barrier/barrierd.c Sat Oct 18 14:05:29 2003
-@@ -38,7 +38,7 @@
- #include <string.h>
- #include <strings.h>
- #include <syslog.h>
--#include <varargs.h>
-+#include <stdarg.h>
- #include "../common/sockcommon.h"
-
- #if !defined(lint) && defined(__NetBSD__)
diff --git a/net/clusterit/files/patch-common::common.c b/net/clusterit/files/patch-common::common.c
deleted file mode 100644
index dc05639cbec2..000000000000
--- a/net/clusterit/files/patch-common::common.c
+++ /dev/null
@@ -1,34 +0,0 @@
-Index: common/common.c
-===================================================================
-RCS file: /cvsroot/src/common/common.c,v
-retrieving revision 1.5
-retrieving revision 1.6
-diff -u -r1.5 -r1.6
---- common/common.c 2001/08/13 21:04:22 1.5
-+++ common/common.c 2001/08/16 19:08:17 1.6
-@@ -1,4 +1,4 @@
--/* $Id: common.c,v 1.5 2001/08/13 21:04:22 garbled Exp $ */
-+/* $Id: common.c,v 1.6 2001/08/16 19:08:17 garbled Exp $ */
- /*
- * Copyright (c) 1998, 1999, 2000
- * Tim Rightnour. All rights reserved.
-@@ -42,7 +42,7 @@
- __COPYRIGHT(
- "@(#) Copyright (c) 1998, 1999, 2000\n\
- Tim Rightnour. All rights reserved\n");
--__RCSID("$Id: common.c,v 1.5 2001/08/13 21:04:22 garbled Exp $");
-+__RCSID("$Id: common.c,v 1.6 2001/08/16 19:08:17 garbled Exp $");
- #endif
-
-
-@@ -91,8 +91,8 @@
- for (i=0; (i < fanout && nodeptr != NULL); i++) {
- l++;
- group = NULL;
-- if (nodeptr->group >= 0)
-- group = strdup(grouplist[nodeptr->group].name);
-+ if (nodeptr->group >= 0 && grouplist[nodeptr->group].name)
-+ group = strdup(grouplist[nodeptr->group].name);
- if (group == NULL)
- (void)printf("Node: %3d Fangroup: %3d Rungroup: None"
- " Host: %-15s\n", l, n + 1, nodeptr->name);
diff --git a/net/clusterit/files/patch-dsh-dsh.c b/net/clusterit/files/patch-dsh-dsh.c
deleted file mode 100644
index 4ef10aaf29d9..000000000000
--- a/net/clusterit/files/patch-dsh-dsh.c
+++ /dev/null
@@ -1,34 +0,0 @@
---- dsh/dsh.c.orig Tue Jul 6 12:49:37 2004
-+++ dsh/dsh.c Tue Jul 6 12:53:51 2004
-@@ -35,6 +35,7 @@
- #include <sys/types.h>
- #include <sys/resource.h>
- #include <sys/wait.h>
-+#include <sys/param.h>
-
- #include <errno.h>
- #include <fcntl.h>
-@@ -76,6 +77,11 @@
- {
- extern char *optarg;
- extern int optind;
-+#if __FreeBSD_version < 500000
-+ extern char *malloc_options;
-+#else
-+ extern const char *_malloc_options;
-+#endif
-
- int someflag, ch, i, fanout, showflag, fanflag;
- char *p, *q, *group, *nodename, *username;
-@@ -93,6 +99,11 @@
- nodeptr = NULL;
- nodelink = NULL;
-
-+#if __FreeBSD_version < 500000
-+ malloc_options = "Z";
-+#else
-+ _malloc_options = "Z";
-+#endif
- rungroup = malloc(sizeof(char **) * GROUP_MALLOC);
- if (rungroup == NULL)
- bailout(__LINE__);
diff --git a/net/clusterit/files/patch-tools::dshbak.src b/net/clusterit/files/patch-tools::dshbak.src
deleted file mode 100644
index cc84ce44bf47..000000000000
--- a/net/clusterit/files/patch-tools::dshbak.src
+++ /dev/null
@@ -1,24 +0,0 @@
---- tools/dshbak.src Sat Apr 5 15:54:14 2003
-+++ tools/dshbak.src Sat Apr 5 15:52:53 2003
-@@ -1,7 +1,10 @@
- #!@@@AWK@@@ -f
- # $Id: dshbak.src,v 1.2 1999/05/05 09:20:45 garbled Exp $
- # dshbak *must have nawk or compatible*
--BEGIN { LASTNODE="null" }
-+BEGIN {
-+ LASTNODE="null"
-+ FS=":"
-+}
- {
- if ($1 != LASTNODE) {
- LASTNODE = $1
-@@ -9,8 +12,7 @@
- gsub(/./,"-",FOO)
- printf("-----%s\nNode %s\n-----%s\n", FOO, $1, FOO)
- }
-- sub(/:/,"!@#$!")
-- sub(/^.*!@#$! /,"")
-+ sub(/^[^:]*: /,"")
- print $0
- }
-
diff --git a/net/clusterit/pkg-plist b/net/clusterit/pkg-plist
index 290b640472c1..5644dcf7a764 100644
--- a/net/clusterit/pkg-plist
+++ b/net/clusterit/pkg-plist
@@ -3,12 +3,13 @@ bin/barrierd
bin/clustersed
bin/dsh
bin/dshbak
+bin/dtop
%%X11%%bin/dvt
bin/jsd
bin/jsh
bin/pcp
bin/pdf
bin/prm
+bin/rseq
bin/run
%%X11%%bin/rvt
-bin/seq