summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-02-23 22:07:38 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-02-23 22:07:38 +0000
commit1085ee534d4a8f5f6f7aee81b48cca6b40535679 (patch)
tree34a46992e85343670b5b7baf4e73384d0dbacfe5
parentAdd tigcc, a C compiler for the TI89, TI92, and TI92+ calculators. (diff)
BROKEN on !i386 and !sparc64: Does not compile
-rw-r--r--japanese/migemo/Makefile8
-rw-r--r--security/opensc/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/japanese/migemo/Makefile b/japanese/migemo/Makefile
index 54fac336a5a6..72c764d72a7a 100644
--- a/japanese/migemo/Makefile
+++ b/japanese/migemo/Makefile
@@ -28,9 +28,15 @@ RUN_DEPENDS+= ${RUBY_SITELIBDIR}/romkan.rb:${PORTSDIR}/japanese/ruby-romkan \
CONFIGURE_ARGS+=--with-rubydir=${RUBY_SITELIBDIR}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386" && ${ARCH} != "sparc64"
+BROKEN= "Does not compile on !i386 and !sparc64"
+.endif
+
post-install:
.if defined(EMACS_PORT_NAME)
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/opensc/Makefile b/security/opensc/Makefile
index d7f74cb271a6..d3aef2cd0033 100644
--- a/security/opensc/Makefile
+++ b/security/opensc/Makefile
@@ -71,4 +71,10 @@ CONFIGURE_ARGS+= --enable-usbtoken
CONFIGURE_ARGS+= --with-plugin-dir=${X11BASE}/lib/mozilla/plugins
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386" && ${ARCH} != "sparc64"
+BROKEN= "Does not compile on !i386 and !sparc64"
+.endif
+
+.include <bsd.port.post.mk>