summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-05-05 17:14:24 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-05-05 17:14:24 +0000
commit0d761e0ce34434078239a25dec585eef7310f912 (patch)
tree3e020c74c8d9ef7b388df3f0b84d5e9cfd9bd311
parentUpdate to 1.1.1 (diff)
UKDistributedView and UKFinderIconCell provides a very flexible icon view.
More precisely, UKDistributedView is an NSTableView-like class that allows arbitrary positioning of evenly-sized items. This is intended for things like the Workspace/Finder's "icon view", and even lets you snap items to a grid in various ways, reorder them etc. Finally it can handle several thousand of items smoothly. WWW: http://www.etoile-project.org/
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/etoile-distributedview/Makefile35
-rw-r--r--deskutils/etoile-distributedview/distinfo3
-rw-r--r--deskutils/etoile-distributedview/pkg-descr3
-rw-r--r--deskutils/etoile-distributedview/pkg-plist8
5 files changed, 50 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index f5ea3d9060f7..87d979b7096b 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -41,6 +41,7 @@
SUBDIR += estickies
SUBDIR += etask
SUBDIR += etoile-dictionaryreader
+ SUBDIR += etoile-distributedview
SUBDIR += etoile-extendedworkspacekit
SUBDIR += etoile-hardware
SUBDIR += etoile-lookandbehavior
diff --git a/deskutils/etoile-distributedview/Makefile b/deskutils/etoile-distributedview/Makefile
new file mode 100644
index 000000000000..92db963b5aa3
--- /dev/null
+++ b/deskutils/etoile-distributedview/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: etoile-distributedview
+# Date created: 22 Dec 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= distributedview
+PORTVERSION= 0.1.${SNAPSHOT}
+CATEGORIES= deskutils gnustep
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= dinoex
+PKGNAMEPREFIX= etoile-
+DISTNAME= Etoile-${SNAPSHOT}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Etoile Project DistributedView framework
+
+USE_BZIP2= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+USE_GNUSTEP_LOCAL_LIBS+= EtoileUI:${ETOILE_UI_PORT}
+DEFAULT_LIBVERSION= 0.1
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
+
+SNAPSHOT= 20061221
+WRKSRC= ${WRKDIR}/Etoile/
+USE_GNUSTEP_MAKE_DIRS+= Frameworks/DistributedView
+
+ETOILE_UI_PORT?= x11/etoile-ui
+
+.include <bsd.port.mk>
diff --git a/deskutils/etoile-distributedview/distinfo b/deskutils/etoile-distributedview/distinfo
new file mode 100644
index 000000000000..545ac18e8091
--- /dev/null
+++ b/deskutils/etoile-distributedview/distinfo
@@ -0,0 +1,3 @@
+MD5 (Etoile-20061221.tar.bz2) = 120ffa8cf06c58ff775f8a218ad91448
+SHA256 (Etoile-20061221.tar.bz2) = 7dc8acbf2cb46d9d119c9817204bbbbe72884065f3287877550c400e68f4c992
+SIZE (Etoile-20061221.tar.bz2) = 9867481
diff --git a/deskutils/etoile-distributedview/pkg-descr b/deskutils/etoile-distributedview/pkg-descr
new file mode 100644
index 000000000000..8ec61c9559df
--- /dev/null
+++ b/deskutils/etoile-distributedview/pkg-descr
@@ -0,0 +1,3 @@
+DistributedView framework
+
+WWW: http://www.etoile-project.org/
diff --git a/deskutils/etoile-distributedview/pkg-plist b/deskutils/etoile-distributedview/pkg-plist
new file mode 100644
index 000000000000..4dceb8af57cb
--- /dev/null
+++ b/deskutils/etoile-distributedview/pkg-plist
@@ -0,0 +1,8 @@
+Local/Library/Headers/DistributedView/Cocoa.h
+Local/Library/Headers/DistributedView/EtoileCompatibility.h
+Local/Library/Headers/DistributedView/UKDistributedView.h
+Local/Library/Headers/DistributedView/UKFinderIconCell.h
+Local/Library/Libraries/libDistributedView.so
+Local/Library/Libraries/libDistributedView.so.%%MAJORLIBVERSION%%
+Local/Library/Libraries/libDistributedView.so.%%LIBVERSION%%
+@dirrm Local/Library/Headers/DistributedView