summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-22 22:13:14 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-22 22:13:14 +0000
commit0b88ec16dcc978e777ddc4c9a82eb38fcda10f78 (patch)
tree8623071cb31f1d8e8aaacfccc958bfc09e200cbe
parentFix port. Apparently I committed a older version. (diff)
Remove old links while creating the new packages
Force creation of the symlink for pkgng to avoid failure if the link already exists Submitted by: ohauer@
-rw-r--r--Mk/bsd.pkgng.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/Mk/bsd.pkgng.mk b/Mk/bsd.pkgng.mk
index 1cd9a8f15c07..b5c0a27422d5 100644
--- a/Mk/bsd.pkgng.mk
+++ b/Mk/bsd.pkgng.mk
@@ -258,6 +258,9 @@ do-package: ${TMPPLIST}
fi; \
fi; \
fi;
+ @for cat in ${CATEGORIES}; do \
+ ${RM} -fv ${PACKAGES}/$$cat/${PKGNAMEPREFIX}${PORTNAME}*${PKG_SUFX} ; \
+ done
@if ${PKG_CREATE} -o ${PKGREPOSITORY} ${PKGNAME}; then \
if [ "${PKGORIGIN}" = "ports-mgmt/pkg" ]; then \
if [ ! -d ${PKGLATESTREPOSITORY} ]; then \
@@ -266,7 +269,7 @@ do-package: ${TMPPLIST}
exit 1; \
fi; \
fi ; \
- ${LN} -s ../${PKGREPOSITORYSUBDIR}/${PKGNAME}${PKG_SUFX} ${PKGLATESTFILE} ; \
+ ${LN} -sf ../${PKGREPOSITORYSUBDIR}/${PKGNAME}${PKG_SUFX} ${PKGLATESTFILE} ; \
fi; \
else \
cd ${.CURDIR} && eval ${MAKE} delete-package; \