summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2001-01-29 15:22:24 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2001-01-29 15:22:24 +0000
commit0aaf43f7bd4043e6c5e23566c1b7867c1343c5aa (patch)
treeb34343da0102e08dbf3f2a4b347e0b2684b86835
parentIncorporate optional DEFAULT_DOMAIN and mysql support. (diff)
Since there is no ability to turn off charset guesser when compiled in, add it
only when specially requested via env. variable
-rw-r--r--www/mnoGoSearch-current/Makefile5
-rw-r--r--www/mnogosearch/Makefile5
-rw-r--r--www/mnogosearch31/Makefile5
3 files changed, 12 insertions, 3 deletions
diff --git a/www/mnoGoSearch-current/Makefile b/www/mnoGoSearch-current/Makefile
index 096310588ece..78827749c95b 100644
--- a/www/mnoGoSearch-current/Makefile
+++ b/www/mnoGoSearch-current/Makefile
@@ -21,10 +21,13 @@ INSTALLS_SHLIB= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared \
- --enable-charset-guesser \
--sysconfdir=${PREFIX}/etc/mnogosearch \
--localstatedir=/var/mnogosearch
+.if defined(WITH_MNOGO_GUESSER)
+CONFIGURE_ARGS+= --enable-charset-guesser
+.endif
+
.if defined(WITH_MNOGO_PGSQL)
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
CONFIGURE_ARGS+= --with-pgsql=${LOCALBASE}/pgsql
diff --git a/www/mnogosearch/Makefile b/www/mnogosearch/Makefile
index 096310588ece..78827749c95b 100644
--- a/www/mnogosearch/Makefile
+++ b/www/mnogosearch/Makefile
@@ -21,10 +21,13 @@ INSTALLS_SHLIB= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared \
- --enable-charset-guesser \
--sysconfdir=${PREFIX}/etc/mnogosearch \
--localstatedir=/var/mnogosearch
+.if defined(WITH_MNOGO_GUESSER)
+CONFIGURE_ARGS+= --enable-charset-guesser
+.endif
+
.if defined(WITH_MNOGO_PGSQL)
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
CONFIGURE_ARGS+= --with-pgsql=${LOCALBASE}/pgsql
diff --git a/www/mnogosearch31/Makefile b/www/mnogosearch31/Makefile
index 096310588ece..78827749c95b 100644
--- a/www/mnogosearch31/Makefile
+++ b/www/mnogosearch31/Makefile
@@ -21,10 +21,13 @@ INSTALLS_SHLIB= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared \
- --enable-charset-guesser \
--sysconfdir=${PREFIX}/etc/mnogosearch \
--localstatedir=/var/mnogosearch
+.if defined(WITH_MNOGO_GUESSER)
+CONFIGURE_ARGS+= --enable-charset-guesser
+.endif
+
.if defined(WITH_MNOGO_PGSQL)
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
CONFIGURE_ARGS+= --with-pgsql=${LOCALBASE}/pgsql