summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-04-20 15:12:29 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-04-20 15:12:29 +0000
commit053520453dc374b6c02b15ad78efd7e0e52867f6 (patch)
tree9715c5e142788fa00b976d2c5a75b984e005be15
parent- Deprecate: irrelevant for supported FreeBSD releases (diff)
- Remove FreeBSD 4.X support from unmaintained ports in categories starting
with letter r-s
-rw-r--r--russian/wmcyrx/Makefile7
-rw-r--r--russian/xcyrBGR/Makefile6
-rw-r--r--security/newpki-client/Makefile8
-rw-r--r--security/newpki-lib/Makefile4
-rw-r--r--security/newpki-server/Makefile4
-rw-r--r--security/openssh/Makefile21
-rw-r--r--security/py-pycrypto/Makefile6
-rw-r--r--security/sfs/Makefile12
-rw-r--r--security/ssh/Makefile10
-rw-r--r--security/vpnd/Makefile12
-rw-r--r--shells/bash2/Makefile2
-rw-r--r--shells/flash/Makefile14
-rw-r--r--shells/viewglob/Makefile8
-rw-r--r--sysutils/bbsmount/Makefile8
-rw-r--r--sysutils/disktool/Makefile8
-rw-r--r--sysutils/disktool/files/patch-disktool.c (renamed from sysutils/disktool/files/extrapatch-disktool.c)0
-rw-r--r--sysutils/heirloom/Makefile8
-rw-r--r--sysutils/pkill/Makefile11
-rw-r--r--sysutils/slmon/Makefile8
-rw-r--r--sysutils/wmbsdbatt/Makefile8
-rw-r--r--sysutils/wmtop/Makefile6
21 files changed, 24 insertions, 147 deletions
diff --git a/russian/wmcyrx/Makefile b/russian/wmcyrx/Makefile
index a51d88305d6e..60310096dcee 100644
--- a/russian/wmcyrx/Makefile
+++ b/russian/wmcyrx/Makefile
@@ -18,12 +18,7 @@ COMMENT= The cyrillic keyboard layout manager for Window Maker
USE_XPM= yes
NO_INSTALL_MANPAGES= yes
PLIST_FILES= bin/wmcyrx2
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 400012
MAKE_ENV+= COPT="${CXXFLAGS} -fpermissive"
-.endif
post-extract:
@ ${MV} ${WRKSRC}/makefile ${WRKSRC}/Makefile
@@ -31,4 +26,4 @@ post-extract:
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/cyrx2 ${PREFIX}/bin/wmcyrx2
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/russian/xcyrBGR/Makefile b/russian/xcyrBGR/Makefile
index c3ee4aadf434..3cf4cb44045a 100644
--- a/russian/xcyrBGR/Makefile
+++ b/russian/xcyrBGR/Makefile
@@ -18,11 +18,7 @@ COMMENT= The bulgarian cyrillic keyboard layout manager for X11
PLIST_FILES= bin/xcyrBGR
USE_XPM= yes
NO_INSTALL_MANPAGES= yes
-
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 400012
MAKE_ENV= COPT="${CXXFLAGS} -fpermissive"
-.endif
post-extract:
@ ${MV} ${WRKSRC}/makefile ${WRKSRC}/Makefile
@@ -30,4 +26,4 @@ post-extract:
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/xcyrBGR ${PREFIX}/bin/xcyrBGR
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/newpki-client/Makefile b/security/newpki-client/Makefile
index 4bb838e9b459..a93c3b9a235b 100644
--- a/security/newpki-client/Makefile
+++ b/security/newpki-client/Makefile
@@ -42,13 +42,7 @@ PLIST_FILES+= share/locale/fr/LC_MESSAGES/newpki-client.mo
CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "does not compile (C++ libraries compiled with conflicting gcc versions)"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/newpki-lib/Makefile b/security/newpki-lib/Makefile
index 5a0c8d1f20be..b6d4fac19ebd 100644
--- a/security/newpki-lib/Makefile
+++ b/security/newpki-lib/Makefile
@@ -37,10 +37,6 @@ GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-USE_GCC= 3.4
-.endif
-
.if ${OSVERSION} >= 700019
BROKEN= does not compile with OpenSSL 0.9.8b
.endif
diff --git a/security/newpki-server/Makefile b/security/newpki-server/Makefile
index bbf1c65c6819..02eff223c4ff 100644
--- a/security/newpki-server/Makefile
+++ b/security/newpki-server/Makefile
@@ -46,10 +46,6 @@ CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-USE_GCC= 3.4
-.endif
-
.if ${OSVERSION} >= 700019
BROKEN= does not compile with OpenSSL 0.9.8b
.endif
diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index 2d21b84dd1ce..d514f71cc3a5 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -58,13 +58,6 @@ CRYPTOLIBS= -L${OPENSSLLIB} -lcrypto
# Here, MANDIR is concetenated to DESTDIR which all forms the man install dir...
MAKE_ENV+= LIBDATADIR=${PREFIX}/libdata MANDIR=${MANPREFIX}/man/man CRYPTOLIBS="${CRYPTOLIBS}"
-.if ${OSVERSION} < 400014
-MAKE_ENV+= COMPAT_GETADDRINFO=yes
-ADDME+= netdb.h
-.else
-MAKE_ENV+= INET6FLAGS=-DINET6
-.endif
-
.if !exists(/usr/include/tcpd.h)
MAKE_ENV+= TCP_WRAPPERS=no
.endif
@@ -126,20 +119,6 @@ pre-configure:
${WRKSRC}/${i}.sed >${WRKSRC}/${i}
.endfor
-.if ${OSVERSION} < 430000
-post-configure:
-.for i in ${FIXME}
- @${MV} ${WRKSRC}/${i} ${WRKSRC}/${i}.sed
- ${SED} -e "s=KERBEROS[:]L=KERBEROS=" \
- -e "s=KERBEROS5[:]L=KERBEROS5=" \
- -e "s=AFS[:]L=AFS=" \
- -e "s=TCP_WRAPPERS[:]L=TCP_WRAPPERS=" \
- -e "s=SKEY[:]L=SKEY=" \
- -e "s=PAM[:]L=PAM=" \
- ${WRKSRC}/${i}.sed >${WRKSRC}/${i}
-.endfor
-.endif
-
pre-install:
-${MKDIR} ${EMPTYDIR}
if ! pw groupshow sshd; then pw groupadd sshd -g 22; fi
diff --git a/security/py-pycrypto/Makefile b/security/py-pycrypto/Makefile
index 825047c20672..7ac26bd45021 100644
--- a/security/py-pycrypto/Makefile
+++ b/security/py-pycrypto/Makefile
@@ -18,13 +18,9 @@ COMMENT= The Python Cryptography Toolkit
USE_PYTHON= yes
USE_PYDISTUTILS=yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000
LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
-.endif
pre-configure:
@${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/setup.py
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/sfs/Makefile b/security/sfs/Makefile
index 69ddde307f9c..f97a5144c90d 100644
--- a/security/sfs/Makefile
+++ b/security/sfs/Makefile
@@ -25,7 +25,10 @@ CONFIGURE_ARGS+=--with-sfsuser=sfs \
--with-sfsgroup=sfs \
--with-sfsdir=/var/spool/sfs \
--with-etcdir=${PREFIX}/etc/sfs \
- --disable-uvfs
+ --disable-uvfs \
+ --with-gmp=${LOCALBASE}
+
+LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
.include <bsd.port.pre.mk>
@@ -33,13 +36,6 @@ CONFIGURE_ARGS+=--with-sfsuser=sfs \
IGNORE= nfsmounter component fails to execute correctly on ${ARCH} systems
.endif
-.if ${OSVERSION} > 500000
-LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
-CONFIGURE_ARGS+=--with-gmp=${LOCALBASE}
-.else
-CONFIGURE_ARGS+=--with-gmp=/usr
-.endif
-
MAN1= \
dirsearch.1 \
newaid.1 \
diff --git a/security/ssh/Makefile b/security/ssh/Makefile
index e6ddaa99cf20..79e91a119e66 100644
--- a/security/ssh/Makefile
+++ b/security/ssh/Makefile
@@ -60,15 +60,13 @@ CONFIGURE_ARGS+= --with-secureid
CONFIGURE_ARGS+= --without-idea
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 500023
LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
MAKE_ENV+= GMPINCDIR="${LOCALBASE}/include" \
GMPLIBDIR="${LOCALBASE}/lib"
-.endif
-.if (${OSVERSION} >= 400016 && !defined(REALLY_WANT_SSH))
+.include <bsd.port.pre.mk>
+
+.if !defined(REALLY_WANT_SSH)
IGNORE= is now deprecated: OpenSSH is a superior version of SSH which has been included in the FreeBSD base system since 4.0-RELEASE. To override this warning set the REALLY_WANT_SSH environment variable and rebuild
.endif
@@ -110,7 +108,7 @@ CONFIGURE_ARGS+= --with-libwrap
# ssh-1.2.27-IPv6-1.5-patch.gz
# We still use WITH_INET6 here and try to support pre 4.0 machines with kame
# IPv6 stack
-.if ${OSVERSION} >= 400014 || ( ${OSVERSION} < 400014 && defined(WITH_INET6) )
+.if defined(WITH_INET6)
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6
diff --git a/security/vpnd/Makefile b/security/vpnd/Makefile
index 811c5674df32..fe4c7ff2985e 100644
--- a/security/vpnd/Makefile
+++ b/security/vpnd/Makefile
@@ -40,14 +40,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.pre.mk>
-
-post-install:
-.if ${OSVERSION} < 500000
- @${ECHO} "================================================================================"
- @${ECHO} "Make sure you set up a few IRQ's for random generation with rndcontrol before"
- @${ECHO} "trying to generate a master key file."
- @${ECHO} "================================================================================"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/shells/bash2/Makefile b/shells/bash2/Makefile
index f0df1e681498..27966ed8d2f5 100644
--- a/shells/bash2/Makefile
+++ b/shells/bash2/Makefile
@@ -52,14 +52,12 @@ MAN1= bash.1 bashbug.1
INFO= bash
post-patch:
-.if ${OSVERSION} >= 500000
@${REINPLACE_CMD} -e "s,.FN /bin/bash,.FN ${PREFIX}/bin/bash," \
${WRKDIR}/${PORTNAME}-${PORTVERSION:R}/doc/bash.1
@${RM} -rf ${WRKSRC}/lib/readline/*.[ch] \
${WRKSRC}/lib/readline/Makefile
@${TOUCH} ${WRKSRC}/lib/readline/Makefile.in
@${REINPLACE_CMD} -E "s,^((RL|HIST)_LIBSRC = ).*,\1/usr/include/readline," ${WRKSRC}/Makefile.in
-.endif
update-etc-shells:
@${ECHO_MSG} "updating /etc/shells"
diff --git a/shells/flash/Makefile b/shells/flash/Makefile
index ed8714b263ad..ec05707f1f10 100644
--- a/shells/flash/Makefile
+++ b/shells/flash/Makefile
@@ -14,13 +14,6 @@ MASTER_SITES= http://www.netsoc.ucd.ie/flash/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= A ncurses-based restriction shell
-.include <bsd.port.pre.mk>
-
-# outdated version of ncurses in non-CURRENT
-.if ${OSVERSION} < 400000
-LIB_DEPENDS= ncurses.5:${PORTSDIR}/devel/ncurses
-.endif
-
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -rdynamic" \
@@ -37,11 +30,6 @@ DATA= system.bg.Netsoc.3 system.bg.Netsoc.4 system.flashlogin \
system.maillogin system.module system.module.9798 system.rc \
system.rc.mailshell
-.if ${OSVERSION} < 400000
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -DHAVE_NCURSES_NCURSES_H" \
- LDFLAGS="-L${LOCALBASE}/lib"
-.endif
-
post-patch:
.for file in ${SCRIPT}
@${REINPLACE_CMD} -e "s:/usr/slocal:${PREFIX}:g" ${WRKSRC}/orcasetup/${file}
@@ -72,4 +60,4 @@ post-install:
@${RM} /etc/shells.bak
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/shells/viewglob/Makefile b/shells/viewglob/Makefile
index 64e88886dea0..aad4fd5107a8 100644
--- a/shells/viewglob/Makefile
+++ b/shells/viewglob/Makefile
@@ -23,10 +23,4 @@ GNU_CONFIGURE= yes
MAN1= vgd.1 vgseer.1 viewglob.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= does not compile on FreeBSD 4.x, it's missing posix_openpt and ptsname functions
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/bbsmount/Makefile b/sysutils/bbsmount/Makefile
index ea98d24bbc2a..2f8d94d0b240 100644
--- a/sysutils/bbsmount/Makefile
+++ b/sysutils/bbsmount/Makefile
@@ -21,13 +21,7 @@ PORTDOCS= README BUGS NEWS AUTHORS ChangeLog
MAN1= bbsmount.1
-.include <bsd.port.pre.mk>
-
post-patch:
-.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/${CONFIGURE_SCRIPT}
-.endif
@${REINPLACE_CMD} -e 's|-O[012]||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -e 's|SUBDIRS = data|SUBDIRS =|' ${WRKSRC}/Makefile.in
@@ -46,4 +40,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/data/bbsmount.bb ${PREFIX}/share/bbtools/bbsmount.bb-sample
@${INSTALL_DATA} ${WRKSRC}/data/bbsmount.bb.ex ${EXAMPLESDIR}/bbsmount.bb.ex
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/disktool/Makefile b/sysutils/disktool/Makefile
index f018ebcb2e20..57651f15c119 100644
--- a/sysutils/disktool/Makefile
+++ b/sysutils/disktool/Makefile
@@ -26,12 +26,6 @@ ALL_TARGET= disktool
MAN1= disktool.1
PLIST_FILES= bin/disktool
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 500000
-EXTRA_PATCHES= ${FILESDIR}/extrapatch-disktool.c
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/Makefile
@@ -40,4 +34,4 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/disktool.man \
${PREFIX}/man/man1/disktool.1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/disktool/files/extrapatch-disktool.c b/sysutils/disktool/files/patch-disktool.c
index c769cc803d7e..c769cc803d7e 100644
--- a/sysutils/disktool/files/extrapatch-disktool.c
+++ b/sysutils/disktool/files/patch-disktool.c
diff --git a/sysutils/heirloom/Makefile b/sysutils/heirloom/Makefile
index af004a7be882..c7ae7bb927cb 100644
--- a/sysutils/heirloom/Makefile
+++ b/sysutils/heirloom/Makefile
@@ -77,12 +77,6 @@ DOC_FILES= CHANGES LICENSE/COPYING LICENSE/LICENSE LICENSE/LUCENT \
# more/NOTES nawk/NOTES oawk/EXPLAIN oawk/NOTES \
# oawk/README ps/NOTES shl/NOTES tar/NOTES
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= does not build on FreeBSD 4.x which is missing wide-characters
-.endif
-
pre-configure:
@${REINPLACE_CMD} ${REINPLACE_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${WRKSRC}/build/mk.config ${WRKSRC}/su/su.dfl.in
@@ -102,4 +96,4 @@ install-doc:
#. endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/pkill/Makefile b/sysutils/pkill/Makefile
index 54df0ee26d11..3b38be191902 100644
--- a/sysutils/pkill/Makefile
+++ b/sysutils/pkill/Makefile
@@ -10,10 +10,13 @@ PORTVERSION= 0.2
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= lioux
+DISTNAME= ${PORTNAME}-current-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= NetBSD's pgrep and pkill: find or signal processes matching criteria
+WRKSRC= ${WRKDIR}/${PORTNAME}-current
+
MAKE_ENV= BINDIR=${PREFIX}/bin \
MANDIR=${PREFIX}/man/man
@@ -26,12 +29,4 @@ MAN1= pgrep.1 pkill.1
IGNORE= "is included in the base system"
.endif
-.if ${OSVERSION} >= 500000
-DISTNAME= ${PORTNAME}-current-${PORTVERSION}
-WRKSRC= ${WRKDIR}/${PORTNAME}-current
-.else
-DISTNAME= ${PORTNAME}-stable-${PORTVERSION}
-WRKSRC= ${WRKDIR}/${PORTNAME}-stable
-.endif
-
.include <bsd.port.post.mk>
diff --git a/sysutils/slmon/Makefile b/sysutils/slmon/Makefile
index 6020e9e9fff2..6408afc4345f 100644
--- a/sysutils/slmon/Makefile
+++ b/sysutils/slmon/Makefile
@@ -31,10 +31,4 @@ PLIST_FILES= bin/slmon
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib -lncurses -lm
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 400010
-LIB_DEPENDS+= ncurses:${PORTSDIR}/devel/ncurses
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/wmbsdbatt/Makefile b/sysutils/wmbsdbatt/Makefile
index 188673166177..638bc54c6303 100644
--- a/sysutils/wmbsdbatt/Makefile
+++ b/sysutils/wmbsdbatt/Makefile
@@ -20,10 +20,4 @@ PLIST_FILES= bin/wmbsdbatt
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmbsdbatt ${PREFIX}/bin
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= does not compile on 4.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/wmtop/Makefile b/sysutils/wmtop/Makefile
index 71a60c732ecd..d33b198a5786 100644
--- a/sysutils/wmtop/Makefile
+++ b/sysutils/wmtop/Makefile
@@ -26,13 +26,9 @@ PLIST_FILES= bin/wmtop
PORTDOCS= BUGS CHANGES COPYING README TODO
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000
post-patch:
${REINPLACE_CMD} -e 's/^\(LIBS.*\)/\1 -lkvm/' ${WRKSRC}/Makefile
${REINPLACE_CMD} -e 's/^\(FLAGS.*\)/\1 -DNO_PROCFS/' ${WRKSRC}/Makefile
-.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmtop ${PREFIX}/bin/
@@ -46,4 +42,4 @@ do-install:
.endfor
.endif # !NOPORTDOCS
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>