summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-12-20 18:15:51 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-12-20 18:15:51 +0000
commit0266ad37bd80d628bd60abeada87e508aa276fa3 (patch)
tree359e46546c25a558c2bbca85ad8a2e19acb6cda5
parent- Use INSTALL_TARGET=install-strip (diff)
- Add LICENSE
- Strip shared library - Use PKGNAMESUFFIX - Simplify MASTER_SITES - Use MAKE_CMD - Bump PORTREVISION for package change - Sort PLIST - Take maintainership
-rw-r--r--textproc/xerces-c3/Makefile36
-rw-r--r--textproc/xerces-c3/pkg-plist10
2 files changed, 25 insertions, 21 deletions
diff --git a/textproc/xerces-c3/Makefile b/textproc/xerces-c3/Makefile
index c29ca48a91a7..648eaadf0ba0 100644
--- a/textproc/xerces-c3/Makefile
+++ b/textproc/xerces-c3/Makefile
@@ -1,31 +1,35 @@
# Created by: gahr
# $FreeBSD$
-PORTNAME= xerces-c3
+PORTNAME= xerces-c
PORTVERSION= 3.1.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= textproc
-MASTER_SITES= ${MASTER_SITE_APACHE}
-MASTER_SITE_SUBDIR= xerces/c/3/sources
-DISTNAME= xerces-c-${PORTVERSION}
+MASTER_SITES= APACHE/xerces/c/3/sources
+PKGNAMESUFFIX= 3
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Validating XML parser from the Apache XML Project
-CONFLICTS= xerces-c2-[0-9]* xerces-c2-devel-[0-9]*
+LICENSE= APACHE20
-USES= gmake pathfix libtool
-USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-pkgconfigdir=${PREFIX}/libdata/pkgconfig \
+CONFLICTS_INSTALL= xerces-c2-[0-9]* xerces-c2-devel-[0-9]*
+
+CONFIGURE_ARGS= --enable-netaccessor-socket \
--enable-transcoder-iconv \
- --enable-netaccessor-socket
-MAKE_ENV+= XERCESCROOT=${WRKSRC}
+ --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+MAKE_ENV= XERCESCROOT=${WRKSRC}
+USE_LDCONFIG= yes
+USES= gmake libtool pathfix
+
+PLIST_SUB= MAJOR_VER=${PORTVERSION:R}
post-install:
- ${LN} -sf libxerces-c-${PORTVERSION:R}.so ${STAGEDIR}${PREFIX}/lib/libxerces-c.so.${PORTVERSION:R:R}
+ ${LN} -s libxerces-c-${PORTVERSION:R}.so ${STAGEDIR}${PREFIX}/lib/libxerces-c.so.${PORTVERSION:R:R}
-test:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
+regression-test test: build
+ cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check
.include <bsd.port.mk>
diff --git a/textproc/xerces-c3/pkg-plist b/textproc/xerces-c3/pkg-plist
index 84711ff1c0b2..aa58ba0688e9 100644
--- a/textproc/xerces-c3/pkg-plist
+++ b/textproc/xerces-c3/pkg-plist
@@ -14,11 +14,6 @@ bin/SCMPrint
bin/SEnumVal
bin/StdInParse
bin/XInclude
-libdata/pkgconfig/xerces-c.pc
-lib/libxerces-c-3.1.so
-lib/libxerces-c.so.3
-lib/libxerces-c.so
-lib/libxerces-c.a
include/xercesc/dom/DOM.hpp
include/xercesc/dom/DOMAttr.hpp
include/xercesc/dom/DOMCDATASection.hpp
@@ -487,3 +482,8 @@ include/xercesc/validators/schema/identity/XercesXPath.hpp
include/xercesc/xinclude/XIncludeDOMDocumentProcessor.hpp
include/xercesc/xinclude/XIncludeLocation.hpp
include/xercesc/xinclude/XIncludeUtils.hpp
+lib/libxerces-c-%%MAJOR_VER%%.so
+lib/libxerces-c.a
+lib/libxerces-c.so
+lib/libxerces-c.so.3
+libdata/pkgconfig/xerces-c.pc