summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 02:54:41 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 02:54:41 +0000
commitf82c84522b047dd99c6f9d85ce3e07217ccce7df (patch)
tree99ec0419390ccc526a97c9a5686f9d3a6e212708
parentUpdate to GNOME 2.6, and add all the new shared library versions. No other (diff)
Add gnomekeyring, an API and daemon for managing lists of credentials. This
is similar to the Keychain in MacOS.
Diffstat (limited to '')
-rw-r--r--security/Makefile1
-rw-r--r--security/gnome-keyring/Makefile28
-rw-r--r--security/gnome-keyring/distinfo2
-rw-r--r--security/gnome-keyring/pkg-descr17
-rw-r--r--security/gnome-keyring/pkg-plist45
-rw-r--r--security/gnomekeyring/Makefile28
-rw-r--r--security/gnomekeyring/distinfo2
-rw-r--r--security/gnomekeyring/pkg-descr17
-rw-r--r--security/gnomekeyring/pkg-plist45
9 files changed, 185 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 03109cfc290f..f6d3efd0fafa 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -99,6 +99,7 @@
SUBDIR += gag
SUBDIR += gcipher
SUBDIR += gnome-ssh-askpass
+ SUBDIR += gnomekeyring
SUBDIR += gnupg
SUBDIR += gnupg-idea
SUBDIR += gnutls
diff --git a/security/gnome-keyring/Makefile b/security/gnome-keyring/Makefile
new file mode 100644
index 000000000000..7beb20658d14
--- /dev/null
+++ b/security/gnome-keyring/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: gnomekeyring
+# Date Created: 08 December 2003
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomekeyring
+PORTVERSION= 0.2.0
+CATEGORIES= security gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/gnome-keyring/0.2
+DISTNAME= gnome-keyring-${PORTVERSION}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A program that keeps passwords and other secrets
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack lthack gtk20
+USE_GMAKE= yes
+USE_LIBTOOL_VER=13
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/security/gnome-keyring/distinfo b/security/gnome-keyring/distinfo
new file mode 100644
index 000000000000..a9ac65ec600b
--- /dev/null
+++ b/security/gnome-keyring/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnome2/gnome-keyring-0.2.0.tar.bz2) = 0735a69355b41ac64c28200ca3675a33
+SIZE (gnome2/gnome-keyring-0.2.0.tar.bz2) = 326210
diff --git a/security/gnome-keyring/pkg-descr b/security/gnome-keyring/pkg-descr
new file mode 100644
index 000000000000..75ce77c6ddfd
--- /dev/null
+++ b/security/gnome-keyring/pkg-descr
@@ -0,0 +1,17 @@
+Gnome-keyring is a program that keep password and other secrets for
+users. It is run as a damon in the session, similar to ssh-agent, and
+other applications can locate it by an environment variable.
+
+The program can manage several keyrings, each with its own master
+password, and there is also a session keyring which is never stored to
+disk, but forgotten when the session ends.
+
+The library libgnome-keyring is used by applications to integrate with
+the gnome keyring system. However, at this point the library hasn't been
+tested and used enought to consider the API to be publically
+exposed. Therefore use of libgnome-keyring is at the moment limited to
+internal use in the gnome desktop. However, we hope that the
+gnome-keyring API will turn out useful and good, so that later it
+can be made public for any application to use.
+
+-- Gnome-keyring README
diff --git a/security/gnome-keyring/pkg-plist b/security/gnome-keyring/pkg-plist
new file mode 100644
index 000000000000..a8cd28094dac
--- /dev/null
+++ b/security/gnome-keyring/pkg-plist
@@ -0,0 +1,45 @@
+bin/gnome-keyring-daemon
+include/gnome-keyring-1/gnome-keyring.h
+lib/libgnome-keyring.a
+lib/libgnome-keyring.so
+lib/libgnome-keyring.so.0
+libdata/pkgconfig/gnome-keyring-1.pc
+libexec/gnome-keyring-ask
+share/locale/ar/LC_MESSAGES/gnome-keyring.mo
+share/locale/az/LC_MESSAGES/gnome-keyring.mo
+share/locale/ca/LC_MESSAGES/gnome-keyring.mo
+share/locale/cs/LC_MESSAGES/gnome-keyring.mo
+share/locale/cy/LC_MESSAGES/gnome-keyring.mo
+share/locale/da/LC_MESSAGES/gnome-keyring.mo
+share/locale/de/LC_MESSAGES/gnome-keyring.mo
+share/locale/el/LC_MESSAGES/gnome-keyring.mo
+share/locale/en_CA/LC_MESSAGES/gnome-keyring.mo
+share/locale/en_GB/LC_MESSAGES/gnome-keyring.mo
+share/locale/es/LC_MESSAGES/gnome-keyring.mo
+share/locale/fi/LC_MESSAGES/gnome-keyring.mo
+share/locale/fr/LC_MESSAGES/gnome-keyring.mo
+share/locale/hr/LC_MESSAGES/gnome-keyring.mo
+share/locale/hu/LC_MESSAGES/gnome-keyring.mo
+share/locale/it/LC_MESSAGES/gnome-keyring.mo
+share/locale/ja/LC_MESSAGES/gnome-keyring.mo
+share/locale/ko/LC_MESSAGES/gnome-keyring.mo
+share/locale/lt/LC_MESSAGES/gnome-keyring.mo
+share/locale/mn/LC_MESSAGES/gnome-keyring.mo
+share/locale/ms/LC_MESSAGES/gnome-keyring.mo
+share/locale/nl/LC_MESSAGES/gnome-keyring.mo
+share/locale/no/LC_MESSAGES/gnome-keyring.mo
+share/locale/pl/LC_MESSAGES/gnome-keyring.mo
+share/locale/pt/LC_MESSAGES/gnome-keyring.mo
+share/locale/pt_BR/LC_MESSAGES/gnome-keyring.mo
+share/locale/ru/LC_MESSAGES/gnome-keyring.mo
+share/locale/sk/LC_MESSAGES/gnome-keyring.mo
+share/locale/sq/LC_MESSAGES/gnome-keyring.mo
+share/locale/sr/LC_MESSAGES/gnome-keyring.mo
+share/locale/sr@Latn/LC_MESSAGES/gnome-keyring.mo
+share/locale/sv/LC_MESSAGES/gnome-keyring.mo
+share/locale/th/LC_MESSAGES/gnome-keyring.mo
+share/locale/tr/LC_MESSAGES/gnome-keyring.mo
+share/locale/uk/LC_MESSAGES/gnome-keyring.mo
+share/locale/zh_CN/LC_MESSAGES/gnome-keyring.mo
+share/locale/zh_TW/LC_MESSAGES/gnome-keyring.mo
+@dirrm include/gnome-keyring-1
diff --git a/security/gnomekeyring/Makefile b/security/gnomekeyring/Makefile
new file mode 100644
index 000000000000..7beb20658d14
--- /dev/null
+++ b/security/gnomekeyring/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: gnomekeyring
+# Date Created: 08 December 2003
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomekeyring
+PORTVERSION= 0.2.0
+CATEGORIES= security gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/gnome-keyring/0.2
+DISTNAME= gnome-keyring-${PORTVERSION}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A program that keeps passwords and other secrets
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack lthack gtk20
+USE_GMAKE= yes
+USE_LIBTOOL_VER=13
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/security/gnomekeyring/distinfo b/security/gnomekeyring/distinfo
new file mode 100644
index 000000000000..a9ac65ec600b
--- /dev/null
+++ b/security/gnomekeyring/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnome2/gnome-keyring-0.2.0.tar.bz2) = 0735a69355b41ac64c28200ca3675a33
+SIZE (gnome2/gnome-keyring-0.2.0.tar.bz2) = 326210
diff --git a/security/gnomekeyring/pkg-descr b/security/gnomekeyring/pkg-descr
new file mode 100644
index 000000000000..75ce77c6ddfd
--- /dev/null
+++ b/security/gnomekeyring/pkg-descr
@@ -0,0 +1,17 @@
+Gnome-keyring is a program that keep password and other secrets for
+users. It is run as a damon in the session, similar to ssh-agent, and
+other applications can locate it by an environment variable.
+
+The program can manage several keyrings, each with its own master
+password, and there is also a session keyring which is never stored to
+disk, but forgotten when the session ends.
+
+The library libgnome-keyring is used by applications to integrate with
+the gnome keyring system. However, at this point the library hasn't been
+tested and used enought to consider the API to be publically
+exposed. Therefore use of libgnome-keyring is at the moment limited to
+internal use in the gnome desktop. However, we hope that the
+gnome-keyring API will turn out useful and good, so that later it
+can be made public for any application to use.
+
+-- Gnome-keyring README
diff --git a/security/gnomekeyring/pkg-plist b/security/gnomekeyring/pkg-plist
new file mode 100644
index 000000000000..a8cd28094dac
--- /dev/null
+++ b/security/gnomekeyring/pkg-plist
@@ -0,0 +1,45 @@
+bin/gnome-keyring-daemon
+include/gnome-keyring-1/gnome-keyring.h
+lib/libgnome-keyring.a
+lib/libgnome-keyring.so
+lib/libgnome-keyring.so.0
+libdata/pkgconfig/gnome-keyring-1.pc
+libexec/gnome-keyring-ask
+share/locale/ar/LC_MESSAGES/gnome-keyring.mo
+share/locale/az/LC_MESSAGES/gnome-keyring.mo
+share/locale/ca/LC_MESSAGES/gnome-keyring.mo
+share/locale/cs/LC_MESSAGES/gnome-keyring.mo
+share/locale/cy/LC_MESSAGES/gnome-keyring.mo
+share/locale/da/LC_MESSAGES/gnome-keyring.mo
+share/locale/de/LC_MESSAGES/gnome-keyring.mo
+share/locale/el/LC_MESSAGES/gnome-keyring.mo
+share/locale/en_CA/LC_MESSAGES/gnome-keyring.mo
+share/locale/en_GB/LC_MESSAGES/gnome-keyring.mo
+share/locale/es/LC_MESSAGES/gnome-keyring.mo
+share/locale/fi/LC_MESSAGES/gnome-keyring.mo
+share/locale/fr/LC_MESSAGES/gnome-keyring.mo
+share/locale/hr/LC_MESSAGES/gnome-keyring.mo
+share/locale/hu/LC_MESSAGES/gnome-keyring.mo
+share/locale/it/LC_MESSAGES/gnome-keyring.mo
+share/locale/ja/LC_MESSAGES/gnome-keyring.mo
+share/locale/ko/LC_MESSAGES/gnome-keyring.mo
+share/locale/lt/LC_MESSAGES/gnome-keyring.mo
+share/locale/mn/LC_MESSAGES/gnome-keyring.mo
+share/locale/ms/LC_MESSAGES/gnome-keyring.mo
+share/locale/nl/LC_MESSAGES/gnome-keyring.mo
+share/locale/no/LC_MESSAGES/gnome-keyring.mo
+share/locale/pl/LC_MESSAGES/gnome-keyring.mo
+share/locale/pt/LC_MESSAGES/gnome-keyring.mo
+share/locale/pt_BR/LC_MESSAGES/gnome-keyring.mo
+share/locale/ru/LC_MESSAGES/gnome-keyring.mo
+share/locale/sk/LC_MESSAGES/gnome-keyring.mo
+share/locale/sq/LC_MESSAGES/gnome-keyring.mo
+share/locale/sr/LC_MESSAGES/gnome-keyring.mo
+share/locale/sr@Latn/LC_MESSAGES/gnome-keyring.mo
+share/locale/sv/LC_MESSAGES/gnome-keyring.mo
+share/locale/th/LC_MESSAGES/gnome-keyring.mo
+share/locale/tr/LC_MESSAGES/gnome-keyring.mo
+share/locale/uk/LC_MESSAGES/gnome-keyring.mo
+share/locale/zh_CN/LC_MESSAGES/gnome-keyring.mo
+share/locale/zh_TW/LC_MESSAGES/gnome-keyring.mo
+@dirrm include/gnome-keyring-1