summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-10-14 12:05:42 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-10-14 12:05:42 +0000
commitf3cbaa1a808778c1445e2c09deddd25e0030bbba (patch)
treea36063a8d50e49600cdaf69c65049cf66e8bf740
parentUpdate to 6.4.1 (diff)
Fix breakage of ccscript on 4.x by lifting requisite commoncpp to gcc 3.4
(and track this for ccaudio which also uses commoncpp)
Diffstat (limited to '')
-rw-r--r--audio/ccaudio/Makefile6
-rw-r--r--audio/ccaudio2/Makefile6
-rw-r--r--devel/commoncpp/Makefile6
-rw-r--r--lang/ccscript/Makefile6
4 files changed, 20 insertions, 4 deletions
diff --git a/audio/ccaudio/Makefile b/audio/ccaudio/Makefile
index 91c3b8ebd6dd..993d47f2fe91 100644
--- a/audio/ccaudio/Makefile
+++ b/audio/ccaudio/Makefile
@@ -19,7 +19,8 @@ LIB_DEPENDS= ccgnu2-1.3.1:${PORTSDIR}/devel/commoncpp
USE_GNOME= gnometarget
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
+USE_INC_LIBTOOL_VER= 15
+USE_GCC= 3.4
INSTALL_TARGET= install man
INSTALLS_SHLIB= yes
@@ -31,4 +32,7 @@ post-patch:
@${REINPLACE_CMD} -e \
's|<stdint\.h>|<stdlib.h>|g' ${WRKSRC}/src/dtmf.cpp
+pre-configure:
+ @${CP} ${LTMAIN} ${WRKSRC}/config
+
.include <bsd.port.mk>
diff --git a/audio/ccaudio2/Makefile b/audio/ccaudio2/Makefile
index 91c3b8ebd6dd..993d47f2fe91 100644
--- a/audio/ccaudio2/Makefile
+++ b/audio/ccaudio2/Makefile
@@ -19,7 +19,8 @@ LIB_DEPENDS= ccgnu2-1.3.1:${PORTSDIR}/devel/commoncpp
USE_GNOME= gnometarget
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
+USE_INC_LIBTOOL_VER= 15
+USE_GCC= 3.4
INSTALL_TARGET= install man
INSTALLS_SHLIB= yes
@@ -31,4 +32,7 @@ post-patch:
@${REINPLACE_CMD} -e \
's|<stdint\.h>|<stdlib.h>|g' ${WRKSRC}/src/dtmf.cpp
+pre-configure:
+ @${CP} ${LTMAIN} ${WRKSRC}/config
+
.include <bsd.port.mk>
diff --git a/devel/commoncpp/Makefile b/devel/commoncpp/Makefile
index d9da8a23055e..852a83647b12 100644
--- a/devel/commoncpp/Makefile
+++ b/devel/commoncpp/Makefile
@@ -25,7 +25,8 @@ CONFIGURE_ARGS= --without-libxml2
USE_GETOPT_LONG= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 15
+USE_INC_LIBTOOL_VER= 15
+USE_GCC= 3.4
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
ac_cv_path_DOXYGEN=no
INSTALLS_SHLIB= yes
@@ -35,4 +36,7 @@ INFO= commoncpp2
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+pre-configure:
+ @${CP} ${LTMAIN} ${WRKSRC}/autoconf
+
.include <bsd.port.mk>
diff --git a/lang/ccscript/Makefile b/lang/ccscript/Makefile
index 21d50e0c359f..53713abbeb9c 100644
--- a/lang/ccscript/Makefile
+++ b/lang/ccscript/Makefile
@@ -18,7 +18,8 @@ COMMENT= State-event driven class extendible C++ script interpreter
LIB_DEPENDS= ccgnu2-1.3.1:${PORTSDIR}/devel/commoncpp
USE_GNOME= gnometarget
-USE_LIBTOOL_VER= 15
+USE_INC_LIBTOOL_VER= 15
+USE_GCC= 3.4
INSTALL_TARGET= install man
INSTALLS_SHLIB= yes
@@ -32,4 +33,7 @@ MAN3= ScriptCommand.3cc ScriptImage.3cc ScriptInterp.3cc \
CFLAGS+= -fPIC
.endif
+pre-configure:
+ @${CP} ${LTMAIN} ${WRKSRC}/config
+
.include <bsd.port.post.mk>