summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-02-20 21:20:07 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-02-20 21:20:07 +0000
commit34bb5fd295f9f48f0c01dbf4cde07a98d3048c8e (patch)
tree5de377155a62bebf5ceafef54a92f1a7818ab591
parent* Re-add libgnomeprintui-2.0 support (diff)
Add qemacs, Quick Emacs, a very small but powerful editor
Submitted by: Brad Davis <so14k@so14k.com>
Diffstat (limited to '')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/qemacs/Makefile34
-rw-r--r--editors/qemacs/distinfo1
-rw-r--r--editors/qemacs/files/patch-Makefile26
-rw-r--r--editors/qemacs/pkg-descr24
-rw-r--r--editors/qemacs/pkg-plist5
6 files changed, 91 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index efe4a29378a4..e41e3ff3cac5 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -131,6 +131,7 @@
SUBDIR += psgml-emacs20
SUBDIR += psgml-mule
SUBDIR += psgml-xemacs21-mule
+ SUBDIR += qemacs
SUBDIR += rox-edit
SUBDIR += sam
SUBDIR += scite
diff --git a/editors/qemacs/Makefile b/editors/qemacs/Makefile
new file mode 100644
index 000000000000..5be682a5c789
--- /dev/null
+++ b/editors/qemacs/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: qemacs
+# Date created: 27 January 2003
+# Whom: Brad Davis <so14k@so14k.com> et al
+#
+# $FreeBSD$
+#
+
+PORTNAME= qemacs
+PORTVERSION= 0.3.p.12
+CATEGORIES= editors
+MASTER_SITES= http://fabrice.bellard.free.fr/qemacs/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p./pre/}
+
+MAINTAINER= so14k@so14k.com
+COMMENT= "QEmacs (for Quick Emacs) is a very small but powerful UNIX editor"
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+MAKE_ARGS+= CFLAGS="${CFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+MAN1= qe.1
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,HOST_CC,CC,g' ${WRKSRC}/Makefile
+
+do-install:
+ cd ${WRKSRC}; ${INSTALL_PROGRAM} qe html2png ${PREFIX}/bin
+ ${MKDIR} ${DATADIR:S/qemacs/qe/}
+ cd ${WRKSRC}; ${INSTALL_DATA} kmaps ligatures ${DATADIR:S/qemacs/qe/}
+ ${INSTALL_MAN} ${WRKSRC}/qe.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/editors/qemacs/distinfo b/editors/qemacs/distinfo
new file mode 100644
index 000000000000..0b0643157744
--- /dev/null
+++ b/editors/qemacs/distinfo
@@ -0,0 +1 @@
+MD5 (qemacs-0.3pre12.tar.gz) = 9768b5439ab73d185e18503b0dbf337f
diff --git a/editors/qemacs/files/patch-Makefile b/editors/qemacs/files/patch-Makefile
new file mode 100644
index 000000000000..21fcb9707c3d
--- /dev/null
+++ b/editors/qemacs/files/patch-Makefile
@@ -0,0 +1,26 @@
+--- Makefile.orig Thu May 2 02:27:40 2002
++++ Makefile Thu Feb 20 21:46:55 2003
+@@ -42,17 +42,17 @@
+ #
+ CONFIG_PNG_OUTPUT=y
+
+-HOST_CC=gcc
+-CC=$(HOST_CC)
++HOST_CC?=gcc
++CC?=$(HOST_CC)
+ PROFILE=
+-CFLAGS=-Wall -O2 -g $(PROFILE)
++CFLAGS?=-Wall -O2 -g $(PROFILE)
+ #CFLAGS+=-fomit-frame-pointer
+ #CPU dependent flags
+-CFLAGS+=-m386 -malign-functions=0
+-LDFLAGS= $(PROFILE)
++#CFLAGS+=-m386 -malign-functions=0
++LDFLAGS?= $(PROFILE)
+ STRIP=strip -s -R .comment -R .note
+ DEFINES=
+-prefix=/usr/local
++prefix?=/usr/local
+
+ ########################################################
+ # do not modify after this
diff --git a/editors/qemacs/pkg-descr b/editors/qemacs/pkg-descr
new file mode 100644
index 000000000000..509d6ce7c20e
--- /dev/null
+++ b/editors/qemacs/pkg-descr
@@ -0,0 +1,24 @@
+QEmacs has features other big editors lack:
+* Full screen editor with an Emacs look and feel with all Emacs common features:
+multi-buffer, multi-window, command mode, universal argument, keyboard macros,
+config file with C like syntax, minibuffer with completion and history.
+* Can edit files of hundreds of Megabytes without being slow by using a highly
+optimized internal representation and by mmaping the file.
+* Full Unicode support, including multi charset handling (8859-x, UTF8, SJIS,
+EUC-JP, ...) and bidirectional editing respecting the Unicode bidi algorithm.
+Arabic and Indic scripts handling (in progress).
+* WYSIWYG HTML/XML/CSS2 mode graphical editing. Also supports lynx like
+rendering on VT100 terminals.
+* WYSIWYG DocBook mode based on XML/CSS2 renderer.
+* C mode: coloring with immediate update. Emacs like auto-indent.
+* Shell mode: colorized VT100 emulation so that your shell work exactly as you
+expect. Compile mode with next/prev error.
+* Input methods for most languages, including Chinese (input methods come from
+the Yudit editor).
+* Hexadecimal editing mode with insertion and block commands. Unicode hexa
+editing is also supported.
+* Works on any VT100 terminals without termcap. UTF8 VT100 support included
+with double width glyphs.
+* Small! Full version (including HTML/XML/CSS2/DocBook rendering and all
+charsets): 200KB big. Basic version (without bidir/unicode
+scripts/input/X11/C/Shell/HTML/dired): 49KB.
diff --git a/editors/qemacs/pkg-plist b/editors/qemacs/pkg-plist
new file mode 100644
index 000000000000..e9089bd3f388
--- /dev/null
+++ b/editors/qemacs/pkg-plist
@@ -0,0 +1,5 @@
+bin/html2png
+bin/qe
+share/qe/kmaps
+share/qe/ligatures
+@dirrm share/qe