summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2002-06-17 02:31:11 +0000
committerGreg Lewis <glewis@FreeBSD.org>2002-06-17 02:31:11 +0000
commit30721b375d6151d48308cf53e835b878468ddb08 (patch)
tree5a06dba08e35029a6e617d3bf3679419e7b38535
parentUnbreak the packing list for this port. As the list of files to (diff)
Make the mud configuration and start up scripts respect PREFIX.
Diffstat (limited to '')
-rw-r--r--net/dgd-lpmud/files/patch-ab6
-rw-r--r--net/dgd-lpmud/scripts/configure11
2 files changed, 15 insertions, 2 deletions
diff --git a/net/dgd-lpmud/files/patch-ab b/net/dgd-lpmud/files/patch-ab
index 285e9a960d4d..30f9fbe48ae3 100644
--- a/net/dgd-lpmud/files/patch-ab
+++ b/net/dgd-lpmud/files/patch-ab
@@ -1,3 +1,5 @@
+$FreeBSD$
+
*** rundgd.old Thu Jan 16 03:13:15 1997
--- rundgd Thu Jan 16 03:28:42 1997
***************
@@ -15,7 +17,7 @@
--- 1,11 ----
#!/bin/sh
-+ dgd=/usr/local/dgd
++ dgd=%%PREFIX%%/dgd
+ cd $dgd/lpmud-2.4.5
passwd=HNAMEPASS
while true
@@ -38,7 +40,7 @@
--- 1,6 ----
telnet_port = 2000; /* telnet port number */
binary_port = 1999; /* binary port number */
-! directory = "/usr/local/dgd/lpmud-2.4.5";/* base directory (MUST be absolute) */
+! directory = "%%PREFIX%%/dgd/lpmud-2.4.5";/* base directory (MUST be absolute) */
users = 40; /* max # of users */
editors = 41; /* max # of editor sessions */
ed_tmpfile = "../tmp/ed"; /* proto editor tmpfile */
diff --git a/net/dgd-lpmud/scripts/configure b/net/dgd-lpmud/scripts/configure
index ba84c2691b52..bcb6d6389441 100644
--- a/net/dgd-lpmud/scripts/configure
+++ b/net/dgd-lpmud/scripts/configure
@@ -1,3 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
cd ${WRKDIR}/mud
mv 2.4.5 lpmud-2.4.5
mv rundgd runlpmud
@@ -5,3 +9,10 @@ ln -s ${PREFIX}/dgd/doc/kfun lpmud-2.4.5/doc
mkdir -p tmp bin; mv hname.c bin
cp ${FILESDIR}/oconv.c bin
cp ${FILESDIR}/Makefile.bin bin/Makefile
+
+FILES_PREFIX="lpmud.dgd runlpmud"
+
+for f in $FILES_PREFIX; do
+ mv ${WRKSRC}/${f} ${WRKSRC}/$f.bak && sed <${WRKSRC}/${f}.bak \
+ s+%%PREFIX%%+${PREFIX}+g >${WRKSRC}/${f}
+done