summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2004-03-19 04:20:12 +0000
committerMaho Nakata <maho@FreeBSD.org>2004-03-19 04:20:12 +0000
commit10e9ee4f10d11c89ce6acacb2a14895b5cf4c319 (patch)
tree59d89caa096eadbf383e94ff3496489231c734fe
parentSIZEify (diff)
Backout previous change of PICFLAG, since
behaviour of -fPIC and -fpic are different. Here is the comment form obrien: -- "-fpic" is a [minor?] optimization for machines that can handle it: -fpic Generate position-independent code (PIC) suitable for use in a shared library, if supported for the target machine. Such code accesses all constant addresses through a global offset table (GOT). The dynamic loader resolves the GOT entries when the program starts (the dynamic loader is not part of GCC; it is part of the operating system). If the GOT size for the linked executable exceeds a machine-specific maximum size, you get an error message from the linker indicating that -fpic does not work; in that case, recompile with -fPIC instead. (These maximums are 16k on the m88k, 8k on the SPARC, and 32k on the m68k and RS/6000. The 386 has no such limit.) -fPIC If supported for the target machine, emit position-independent code, suitable for dynamic linking and avoiding any limit on the size of the global offset table. This option makes a difference on the m68k, m88k, and the SPARC. Thanks to: obrien
Diffstat (limited to '')
-rw-r--r--biology/pymol/Makefile6
-rw-r--r--math/atlas-devel/Makefile6
-rw-r--r--math/atlas/Makefile6
3 files changed, 18 insertions, 0 deletions
diff --git a/biology/pymol/Makefile b/biology/pymol/Makefile
index 7f3895d78b36..d53214185a48 100644
--- a/biology/pymol/Makefile
+++ b/biology/pymol/Makefile
@@ -28,7 +28,13 @@ USE_PYTHON= yes
.include <bsd.port.pre.mk>
+.if !defined(PICFLAG)
+.if ${MACHINE_ARCH} == "sparc64"
PICFLAG=-fPIC
+.else
+PICFLAG=-fpic
+.endif
+.endif
pre-patch:
@${INSTALL_DATA} ${WRKSRC}/setup/Rules.linux ${WRKSRC}/Rules.make
diff --git a/math/atlas-devel/Makefile b/math/atlas-devel/Makefile
index a5fe33e93454..e184cfa2e292 100644
--- a/math/atlas-devel/Makefile
+++ b/math/atlas-devel/Makefile
@@ -50,7 +50,13 @@ post-patch:
@(cd ${WRKSRC}; ${PATCH} < ${FILESDIR}/alpha-patch)
.endif
+.if !defined(PICFLAG)
+.if ${MACHINE_ARCH} == "sparc64"
PICFLAG=-fPIC
+.else
+PICFLAG=-fpic
+.endif
+.endif
ANSWER_i386?= ${PRINTF} "\n\n\n\n\n\n\n\n\n\n"
ANSWER_ia64?= ${PRINTF} "\n\n\n2\n\n\n\n\nf77\n-O2 -static\n\n"
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index 42e8ddbf50be..a3a0fc74d800 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -49,7 +49,13 @@ post-patch:
@(cd ${WRKSRC}; ${PATCH} < ${FILESDIR}/alpha-patch)
.endif
+.if !defined(PICFLAG)
+.if ${MACHINE_ARCH} == "sparc64"
PICFLAG=-fPIC
+.else
+PICFLAG=-fpic
+.endif
+.endif
ANSWER_i386?= ${PRINTF} "\n\n\n\n\n\n\n\n\n\n"
ANSWER_ia64?= ${PRINTF} "\n\n\n2\n\n\n\n\nf77\n-O2 -static\n\n"