summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexey Shchepin <alexey@process-one.net>2017-11-02 17:03:30 +0300
committerAlexey Shchepin <alexey@process-one.net>2017-11-02 18:21:40 +0300
commit78dfb832b8e5b711cfbbe3131493057325c0008d (patch)
tree8b3148730887908a2c6e676e6ce159b24b6d05d8 /configure.ac
parentFix pkix:validate() return value (diff)
Add SQL_INSERT macro and update SQL queries to use server_host field
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1fdf3029..17d32ac1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,6 +84,14 @@ AC_ARG_ENABLE(roster_gateway_workaround,
*) AC_MSG_ERROR(bad value ${enableval} for --enable-roster-gateway-workaround) ;;
esac],[roster_gateway_workaround=false])
+AC_ARG_ENABLE(new_sql_schema,
+[AC_HELP_STRING([--enable-new-sql-schema], [use new SQL schema (default: no)])],
+[case "${enableval}" in
+ yes) new_sql_schema=true ;;
+ no) new_sql_schema=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-new-sql-schema) ;;
+esac],[new_sql_schema=false])
+
AC_ARG_ENABLE(full_xml,
[AC_HELP_STRING([--enable-full-xml], [use XML features in XMPP stream (ex: CDATA) (default: no, requires XML compliant clients)])],
[case "${enableval}" in
@@ -273,6 +281,7 @@ fi
AC_SUBST(hipe)
AC_SUBST(roster_gateway_workaround)
+AC_SUBST(new_sql_schema)
AC_SUBST(full_xml)
AC_SUBST(db_type)
AC_SUBST(odbc)