summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStu Tomlinson <stu@nosnilmot.com>2020-12-23 12:41:13 +0000
committerStu Tomlinson <stu@nosnilmot.com>2020-12-23 12:41:13 +0000
commit1f60f5d8afc6fd2507c494d13aeaee31752803c1 (patch)
tree95044850c1ed615ca91e7fa73eb90c43cd79b076 /configure.ac
parentFix invalid timezone in mod_time (issue #3454) (diff)
Remove external dependency on sqlite3 for macos
On macos, erlang-sqlite3 is built using amalgamated sqlite3 library, there is no external sqlite3 dependency required
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 13 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 0551c313..86b9c3bb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -270,12 +270,19 @@ AC_ARG_ENABLE(zlib,
*) AC_MSG_ERROR(bad value ${enableval} for --enable-zlib) ;;
esac],[if test "x$zlib" = "x"; then zlib=true; fi])
-if test "$sqlite" = "true"; then
- AX_LIB_SQLITE3([3.6.19])
- if test "x$SQLITE3_VERSION" = "x"; then
- AC_MSG_ERROR(SQLite3 library >= 3.6.19 was not found)
- fi
-fi
+case "`uname`" in
+ "Darwin")
+ # Darwin (macos) erlang-sqlite is built using amalgamated lib, so no external dependency
+ ;;
+ *)
+ if test "$sqlite" = "true"; then
+ AX_LIB_SQLITE3([3.6.19])
+ if test "x$SQLITE3_VERSION" = "x"; then
+ AC_MSG_ERROR(SQLite3 library >= 3.6.19 was not found)
+ fi
+ fi
+ ;;
+esac
enabled_backends=""
for backend in odbc mysql pgsql sqlite redis mssql; do