summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMickaël Rémond <mremond@process-one.net>2015-01-29 18:43:47 +0100
committerMickaël Rémond <mremond@process-one.net>2015-02-10 17:56:44 +0100
commit01e1f677c72b923251f7021bc024319ff129d42d (patch)
tree38c3101d86f42b62774df909193cdfe6be69614c /configure.ac
parentDocument EJABBERD_CONFIG_PATH in ejabberdctl.cfg (diff)
Add Elixir support to ejabberd
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index ddbc48b8..8715c86b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,10 +106,10 @@ AC_ARG_ENABLE(mssql,
esac],[db_type=generic])
AC_ARG_ENABLE(all,
-[AC_HELP_STRING([--enable-all], [same as --enable-nif --enable-odbc --enable-mysql --enable-pgsql --enable-pam --enable-zlib --enable-riak --enable-json --enable-iconv --enable-debug --enable-lager --enable-tools (useful for Dialyzer checks, default: no)])],
+[AC_HELP_STRING([--enable-all], [same as --enable-nif --enable-odbc --enable-mysql --enable-pgsql --enable-pam --enable-zlib --enable-riak --enable-json --enable-elixir --enable-iconv --enable-debug --enable-lager --enable-tools (useful for Dialyzer checks, default: no)])],
[case "${enableval}" in
- yes) nif=true odbc=true mysql=true pgsql=true pam=true zlib=true riak=true json=true iconv=true debug=true lager=true tools=true ;;
- no) nif=false odbc=false mysql=false pgsql=false pam=false zlib=false riak=false json=false iconv=false debug=false lager=false tools=false ;;
+ yes) nif=true odbc=true mysql=true pgsql=true pam=true zlib=true riak=true json=true elixir=true iconv=true debug=true lager=true tools=true ;;
+ no) nif=false odbc=false mysql=false pgsql=false pam=false zlib=false riak=false json=false elixir=false iconv=false debug=false lager=false tools=false ;;
*) AC_MSG_ERROR(bad value ${enableval} for --enable-all) ;;
esac],[])
@@ -185,6 +185,14 @@ AC_ARG_ENABLE(json,
*) AC_MSG_ERROR(bad value ${enableval} for --enable-json) ;;
esac],[if test "x$json" = "x"; then json=false; fi])
+AC_ARG_ENABLE(elixir,
+[AC_HELP_STRING([--enable-elixir], [enable Elixir support (default: no)])],
+[case "${enableval}" in
+ yes) elixir=true ;;
+ no) elixir=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-elixir) ;;
+esac],[if test "x$elixir" = "x"; then elixir=false; fi])
+
AC_ARG_ENABLE(iconv,
[AC_HELP_STRING([--enable-iconv], [enable iconv support (default: yes)])],
[case "${enableval}" in
@@ -240,6 +248,7 @@ AC_SUBST(pam)
AC_SUBST(zlib)
AC_SUBST(riak)
AC_SUBST(json)
+AC_SUBST(elixir)
AC_SUBST(iconv)
AC_SUBST(debug)
AC_SUBST(lager)