summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHolger Weiss <holger@zedat.fu-berlin.de>2020-04-20 00:37:41 +0200
committerHolger Weiss <holger@zedat.fu-berlin.de>2020-04-20 00:37:41 +0200
commitb1b3c4cdcfc8c8cd3448413bb4af01459180fc5b (patch)
tree271bfcefd30d1a489e46f723604e3000abaaaf45 /configure.ac
parentTravis CI: Test against Erlang/OTP 22.3 (diff)
Enable STUN/TURN by default
Build ejabberd with STUN/TURN support by default, and add a STUN/TURN listener to the example configuration file.
Diffstat (limited to '')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2d98f62f..52239313 100644
--- a/configure.ac
+++ b/configure.ac
@@ -213,12 +213,12 @@ AC_ARG_ENABLE(system_deps,
esac],[if test "x$system_deps" = "x"; then system_deps=false; fi])
AC_ARG_ENABLE(stun,
-[AC_HELP_STRING([--enable-stun], [enable STUN/TURN support (default: no)])],
+[AC_HELP_STRING([--enable-stun], [enable STUN/TURN support (default: yes)])],
[case "${enableval}" in
yes) stun=true ;;
no) stun=false ;;
*) AC_MSG_ERROR(bad value ${enableval} for --enable-stun) ;;
-esac],[if test "x$stun" = "x"; then stun=false; fi])
+esac],[if test "x$stun" = "x"; then stun=true; fi])
AC_ARG_ENABLE(sip,
[AC_HELP_STRING([--enable-sip], [enable SIP support (default: no)])],