summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBadlop <badlop@process-one.net>2022-02-04 16:44:56 +0100
committerBadlop <badlop@process-one.net>2022-02-11 09:39:02 +0100
commit9661d06334d8b84f3420817a3fb346601ae859a5 (patch)
treefd0331a834db7e5213b57861650325c103e57f84 /configure.ac
parentDisable mssql in Actions: it's known mssql doesn't pass the tests (diff)
Remove obsolete db_type defined environment
db_type as a compilation define was first introduced in 2006 in d0e2ac9, but was removed in 2015 in 25791cf. Nowadays: ./configure --enable-mssql will set {mssql, true} in vars.config; That is read by ejabberd.app.src.script to set enabled_backends; which is consulted by test/suite.erl to test only available backends.
Diffstat (limited to '')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 7a6ceb86..e203eab6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -143,10 +143,10 @@ esac],[if test "x$lua" = "x"; then lua=false; fi])
AC_ARG_ENABLE(mssql,
[AS_HELP_STRING([--enable-mssql],[use Microsoft SQL Server database (default: no, requires --enable-odbc)])],
[case "${enableval}" in
- yes) db_type=mssql; mssql=true ;;
- no) db_type=generic; mssql=false ;;
+ yes) mssql=true ;;
+ no) mssql=false ;;
*) AC_MSG_ERROR(bad value ${enableval} for --enable-mssql) ;;
-esac],[db_type=generic; if test "x$mssql" = "x"; then mssql=false; fi])
+esac],[if test "x$mssql" = "x"; then mssql=false; fi])
AC_ARG_ENABLE(mysql,
[AS_HELP_STRING([--enable-mysql],[enable MySQL support (default: no)])],
@@ -283,7 +283,6 @@ esac
AC_SUBST(roster_gateway_workaround)
AC_SUBST(new_sql_schema)
AC_SUBST(full_xml)
-AC_SUBST(db_type)
AC_SUBST(odbc)
AC_SUBST(mssql)
AC_SUBST(mysql)