summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaweł Chmielowski <pchmielowski@process-one.net>2017-05-31 11:30:34 +0200
committerPaweł Chmielowski <pchmielowski@process-one.net>2017-05-31 11:30:34 +0200
commit5d3870faa3637b22a60493beea4af5b6695cccb4 (patch)
treeeb04d8bb8d61cbe6508aa0ba6b3dc5812f71c14b /configure.ac
parentAdd license files into lib and deps directories (diff)
Add --enable-system-deps configure option
Diffstat (limited to '')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aa92cf38..884db5d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -212,6 +212,14 @@ AC_ARG_ENABLE(latest_deps,
*) AC_MSG_ERROR(bad value ${enableval} for --enable-latest-deps) ;;
esac],[if test "x$latest_deps" = "x"; then latest_deps=false; fi])
+AC_ARG_ENABLE(system_deps,
+[AC_HELP_STRING([--enable-system-deps], [makes rebar use localy installed dependences instead of downloading them (default: no)])],
+[case "${enableval}" in
+ yes) system_deps=true ;;
+ no) system_deps=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-system-deps) ;;
+esac],[if test "x$system_deps" = "x"; then system_deps=false; fi])
+
AC_ARG_ENABLE(stun,
[AC_HELP_STRING([--enable-stun], [enable STUN/TURN support (default: no)])],
[case "${enableval}" in
@@ -274,6 +282,7 @@ AC_SUBST(sip)
AC_SUBST(debug)
AC_SUBST(tools)
AC_SUBST(latest_deps)
+AC_SUBST(system_deps)
AC_SUBST(CFLAGS)
AC_SUBST(CPPFLAGS)
AC_SUBST(LDFLAGS)