summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBadlop <badlop@process-one.net>2022-01-26 16:58:01 +0100
committerBadlop <badlop@process-one.net>2022-02-03 18:21:49 +0100
commit3b30d5b0ed9613634b39fae23ddd3001b875b8fe (patch)
tree2c0e05fdb5bc2a200c498c21eb9112bf56a1ad92 /configure.ac
parentNew "make relive" similar to "ejabberdctl live" without installing (diff)
Fix support for MSSQL testing
Diffstat (limited to '')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b086a7b6..ae85c0d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -146,7 +146,7 @@ AC_ARG_ENABLE(mssql,
yes) db_type=mssql; mssql=true ;;
no) db_type=generic; mssql=false ;;
*) AC_MSG_ERROR(bad value ${enableval} for --enable-mssql) ;;
-esac],[db_type=generic])
+esac],[if test "x$mssql" = "x"; then db_type=generic; mysql=false; fi])
AC_ARG_ENABLE(mysql,
[AS_HELP_STRING([--enable-mysql],[enable MySQL support (default: no)])],
@@ -285,6 +285,7 @@ AC_SUBST(new_sql_schema)
AC_SUBST(full_xml)
AC_SUBST(db_type)
AC_SUBST(odbc)
+AC_SUBST(mssql)
AC_SUBST(mysql)
AC_SUBST(pgsql)
AC_SUBST(sqlite)