summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStu Tomlinson <stu@nosnilmot.com>2020-09-21 15:14:12 +0100
committerStu Tomlinson <stu@nosnilmot.com>2020-09-21 15:14:12 +0100
commit0fc1aea379924b6f83f274f173d0bbd163cae1c2 (patch)
treeb35f01e07b343f11bd9c91d4b6726d8b1d2cc2e5 /configure.ac
parentrebar3 plugin to support configure-deps command (#3392) (diff)
rebar3 support for main build process
This adds support for building, and installing, ejabberd using rebar3 A --with-rebar=/path/to/rebar3 option is added to configure to specify which rebar to use rebar2 compatibility is maintained, and the bundled rebar2 is still used by default
Diffstat (limited to '')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9f9dc89f..0551c313 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,16 @@ else
fi
])
+AC_ARG_WITH(rebar,
+ AC_HELP_STRING([--with-rebar=bin],
+ [use rebar specified]),
+[if test "$withval" = "yes" -o "$withval" = "no" -o "X$with_rebar" = "X"; then
+ rebar="rebar"
+else
+ rebar="$with_rebar"
+fi
+], [rebar="rebar"])
+
AC_PATH_TOOL(ERL, erl, , [${extra_erl_path}$PATH])
AC_PATH_TOOL(ERLC, erlc, , [${extra_erl_path}$PATH])
AC_PATH_TOOL(EPMD, epmd, , [${extra_erl_path}$PATH])
@@ -289,6 +299,7 @@ AC_SUBST(pgsql)
AC_SUBST(sqlite)
AC_SUBST(pam)
AC_SUBST(zlib)
+AC_SUBST(rebar)
AC_SUBST(redis)
AC_SUBST(elixir)
AC_SUBST(stun)